Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12207 closed defect (duplicate)

show_when_type = ... kills TicketTemplate

Reported by: Theodor Norup Owned by: Rob Guttman
Priority: normal Component: DynamicFieldsPlugin
Severity: major Keywords:
Cc: Trac Release: 1.0

Description

In Trac 1.0.1 with DynamicFieldsPlugin and TracTicketTemplatePlugin installed, the ticket template functionality in the ticket editor is completely disabled (the admin functionality works, though) when you use the show_when_type configuration setting is used on a custom ticket field.

It seems that the problem lies on the Javascript side. On load of newticket firebug reports:

TypeError: th.attr(...) is undefined
return th.attr('id').slice(2);

in layout.js line 156, col 11. The same error is reported whenever you change the ticket type setting. The dynamic field behaviour works as expected, the field is nicely hidden when expected to.

When you outcomment the trac.conf line containing show_when_type the template functionality works fine

Attachments (0)

Change History (5)

comment:1 Changed 4 years ago by Theodor Norup

Forgot: DynamicFieldsPlugin version is 2.2.0dev (0.12 branch). TracTicketTemplatePlugin is version 0.9dev

comment:2 Changed 4 years ago by Rob Guttman

Please try the 0.11 branch instead. The 0.12 branch has not been as maintained.

comment:3 Changed 4 years ago by Ryan J Ollos

I recently merged both branches into dynamicfieldsplugin/trunk, so it should have all the latest changes. If you can reproduce the issue with the trunk I'll take a look.

Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:4 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #9605.

comment:5 Changed 4 years ago by Theodor Norup

Right, trunk works nicely in my setup.

Thanks for helping. (And why not warn against use of 0.11 and 0.12?)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Rob Guttman.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.