Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12309 closed defect (fixed)

Permissions are reset everytime the plugin UI is opened

Reported by: vidr@… Owned by: Ryan J Ollos
Priority: high Component: SvnAuthzAdminPlugin
Severity: critical Keywords:
Cc: Trac Release: 1.0

Description

I am setting a permission in authz either using the plugin UI or by manually editing the file.

[groups]
srvadmin = peter, pan

[services:/]
@srvadmin = r
john = rw
jane = rw

After that, if i open/launch "Subversion Access" UI; the permissions for the group or user is set to blank.
So it shows up as:

[groups]
srvadmin = peter, pan

[services:/]
@srvadmin = 
john = 
jane = 

Can it be fixed?
Source used: https://trac-hacks.org/changeset/14583/svnauthzadminplugin/1.0/svnauthz

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by vidr@…

Any updates, dude?

comment:2 Changed 7 years ago by Ryan J Ollos

I spent a few hours on this plugin last weekend and decided it was in such bad shape that it pretty much needs an entire rewrite. That's fine with me anyway because I don't like the interface and it's GPL licensed. I prefer to work on BSD license because I can freely migrate code to the Trac core.

I'll try to patch this issue over the weekend, but overall I'm not optimistic about the plugin.

comment:3 Changed 7 years ago by vidr@…

Hi,

If you think this plugin will not work.
Can i ask you to suggest an alternative for SVN Authz file UI?

comment:4 Changed 7 years ago by Ryan J Ollos

If you just want to edit the Authz file through the web interface you could try TracSvnAuthzPlugin. It appears to be similar to FineGrainedPageAuthzEditorPlugin, which might work as well for the purpose of editing the Authz file, or could at least be hacked to make it work.

comment:5 Changed 7 years ago by anonymous

This is a regression bug introduced in diff:svnauthzadminplugin/1.0/svnauthz/io.py@14491:14494

In _parse_path_acl the variables acl and aclstr are merged into acl, resulting in one overwriting the other. source:svnauthzadminplugin/1.0/svnauthz/io.py@14494:121-122#L120

comment:6 Changed 7 years ago by Ryan J Ollos

Thanks for tracking that down. I was being careless in trying to cleanup the codebase. I'll commit the fix today.

comment:7 Changed 7 years ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

In 14687:

1.0dev: Fixed regression in [14494]. Fixes #12309.

Thanks to vidr@… for the patch.

comment:8 Changed 7 years ago by Ryan J Ollos

Please open a new ticket if you spot any other issues with the plugin. We'd like to use the plugin on trac-hacks.org, so eventually I'll spend the time to redesign the plugin and add unit tests.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.