Modify

Opened 8 years ago

Closed 7 years ago

#12310 closed defect (duplicate)

Query milestone parameter causes error

Reported by: Brian Sipos Owned by: Ryan J Ollos
Priority: normal Component: TracTicketStatsPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

If a ticketstats URL is used with query parameters, and if those parameters include a desired milestone, then then plugin will error-out with a "method not found" error. The failing line is attempting to call "find" on a "list" object.

I will attach a working patch which honors a milestone query parameter.

Attachments (1)

trac-ticketstats-plugin-2.2.0-milestone-find.patch (497 bytes) - added by Brian Sipos 8 years ago.
tested patch

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by Brian Sipos

tested patch

comment:1 Changed 8 years ago by Ryan J Ollos

Status: newaccepted

Thank you for the patch. I will try to review this weekend.

comment:2 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: acceptedclosed

Duplicate of #8300. Could you try running the trunk version?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.