Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12463 closed defect (fixed)

Adding versions for all projects not working

Reported by: massimo.b@… Owned by: Cinc-th
Priority: normal Component: SimpleMultiProjectPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

This is trac-1.0.5 and latest SimpleMultiProject from svn.

Adding versions, the "Add" button is only enabled if at least one project is selected. I like to add a version "devel" for all projects by selecting no project at all as described there in the note.

My [ticket-custom] for the project is set like this:

project = select
project.invalid_if.1 = select...
project.label = Project
project.options = Internal:Trac|GIS|DOR_R4.0|BS_R4.0|foo|da|main|PM|P4|R_R4.1|select...
project.value = select...

Attachments (0)

Change History (6)

comment:1 Changed 7 years ago by Cinc-th

There is a config setting to allow no projects when creating milestones and versions. Go to Admin->Plugins->SimpleMultiProjectPlugin for documentation.

Yes, the wiki page should document these settings.

comment:2 Changed 7 years ago by massimo.b@…

Thanks, I have set this now:

[simple-multi-project]
milestone_without_project = True
version_without_project = True

comment:3 Changed 7 years ago by massimo.b@…

Adding a version for no project is possible now. This version should appear for all projects, but it does not appear at all in the new ticket mask.

comment:4 Changed 7 years ago by Cinc-th

Owner: changed from falkb to Cinc-th
Status: newaccepted

The problem is after calling

SmpModel.get_versions_of_project(project)

in ticket.py

post_process_request(self, req, template, data, content_type)

in line 70. Versions without a project are not added to the version list.

comment:5 Changed 7 years ago by Cinc-th

Resolution: fixed
Status: acceptedclosed

In 14972:

Add versions not linked to any project to the list of available versions for a project.

Fixes #12463.

comment:6 Changed 7 years ago by massimo.b@…

Tested: ok Thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Cinc-th.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.