Modify

Opened 7 years ago

Closed 7 years ago

#12525 closed defect (duplicate)

ValueError: invalid literal for int() with base 10: '#7'

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Today, I downloaded a latest MasterTicketsPlugin, and I made it into TracMasterTickets-4.0.0dev_r0-py2.7.egg.

It seems the same issue related to #8830.

Trac version is 1.0.2 and Python version is 2.7.9. These are distributed packages on Debian (Jessie).

Python Traceback

Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/trac/web/main.py"、line 512、in _dispatch_request
  dispatcher.dispatch(req)
File "/usr/lib/python2.7/dist-packages/trac/web/main.py"、line 231、in dispatch
  self._post_process_request(req, *resp)
File "/usr/lib/python2.7/dist-packages/trac/web/main.py"、line 346、in _post_process_request
  resp = f.post_process_request(req, *resp)
File "build/bdist.linux-x86_64/egg/mastertickets/web_ui.py"、line 94、in post_process_request
  new = set([int(n) for n in field_data['new'].split(',')])

Local Variables:

Name          Value
add           set([7])
change        {'comment': '', 'author': u'user', 'fields': {u'blockedby': {'new': ...
content_type  None
data          {'comment': None, 'change_preview': {'comment': None, 'fields': {}, ...
elms          <Fragment>
field         u'blockedby'
field_data    {'new': u'#7', 'old': u'7', 'label': u'blockedby'}
links         <mastertickets.model.TicketLinks #6 blocking=[] blocked_by=[]>
n             u'#7'
new           set([7])
old           set([])
req           <RequestWithSession "GET '/ticket/6'">
self          <mastertickets.web_ui.MasterTicketsModule object at 0x7f88e329fe50>
sub           set([])
template      'ticket.html'
tkt           <trac.ticket.model.Ticket object at 0x7f88d83fac90>

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #11932.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.