Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12606 closed defect (duplicate)

WindowsError: (5, 'Access is denied')

Reported by: admin Owned by:
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a GET operation on /browser, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'path': '/'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

System Information

Trac 0.12.4.ja1
Babel 0.9.5
CustomFieldAdmin 0.2.8
Docutils 0.7
Genshi 0.6 (without speedups)
GIT 1.9.5.msysgit.1
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 1.3.1
pysqlite 2.4.1
Python 2.6.6 (r266:84297, Aug 24 2010, 18:46:32) [MSC v.1500 32 bit (Intel)]
RPC 1.1.2-r9970
setuptools 0.6c11
SQLite 3.5.9
Subversion 1.6.17 (r1128011)
jQuery 1.4.4

Enabled Plugins

advancedticketworkflowplugin 0.11dev-r9962
batchmodify 0.8.0a1-trac0.12
blockdiagplugin 0.5.1
exceldownloadplugin 0.12.0.1
footnotemacro 1.03
hudsontracplus 0.4
iniadmin 0.2
lightningtheme 1.0
newwikipagebutton 1.01
privatewikis 1.0.0
reportincludeplugin 0.5-snapshot
svnauthzadminplugin 0.1.2.-moved.to.trac.0.11-
ticket-clone Rev
ticketimport 0.8
trac-jsgantt 0.2.0-ja
tracaccountmanager 0.3
tracaddcommentmacro 0.3
tracautowikify 0.1
tracavatarplugin 0.3
traccompleteuserplugin 0.4
traccustomfieldadmin 0.2.8
tracdatefield 1.0.1
tracdiscussion 0.8-r9877
tracdragdrop 0.12.0.10
tracflashembedmacro 0.95rc1
tracganttcalendarplugin 0.5-r801
tracgit 0.12.0.5dev
tracmacostheme 1.0.3
tracmacropost 0.2
tracnav 4.2.dev
tracquerychart 0.2.3
tracsectioneditplugin 0.1
tracsubticketsplugin 0.1.1.dev-20130429
tracthemeengine 2.0.1
tractocmacro 11.0.0.3
tracusermanagerplugin 0.4r5520
tracwysiwyg 0.12.0.4-r9676
tracxdocview 0.1
tracxmlrpc 1.1.2-r9970
workfloweditorplugin 1.1.5

Python Traceback

Traceback (most recent call last):
  File "C:\TracLight\python\lib\site-packages\trac-0.12.4.ja1-py2.6.egg\trac\web\main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "C:\TracLight\python\lib\site-packages\trac-0.12.4.ja1-py2.6.egg\trac\web\main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\TracLight\python\lib\site-packages\trac-0.12.4.ja1-py2.6.egg\trac\versioncontrol\web_ui\browser.py", line 391, in process_request
    dir_data = self._render_dir(req, repos, node, rev, order, desc)
  File "C:\TracLight\python\lib\site-packages\trac-0.12.4.ja1-py2.6.egg\trac\versioncontrol\web_ui\browser.py", line 553, in _render_dir
    entries = [entry(n) for n in node.get_entries()
  File "build\bdist.win32\egg\tracext\git\git_fs.py", line 544, in get_entries
    yield GitNode(self.repos, ent[-1], self.rev, self.log, ent, historian)
  File "C:\TracLight\python\Lib\contextlib.py", line 23, in __exit__
    self.gen.next()
  File "build\bdist.win32\egg\tracext\git\PyGIT.py", line 760, in get_historian
    p[0].terminate()
  File "C:\TracLight\python\Lib\subprocess.py", line 949, in terminate
    _subprocess.TerminateProcess(self._handle, 1)
WindowsError: [Error 5] ƒAƒNƒZƒX‚ª‹‘”Û‚³‚ê‚Ü‚µ‚½B

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Jun Omae

Component: SELECT A HACKGitPlugin
Resolution: duplicate
Status: newclosed

A duplicate of #9646.

comment:2 Changed 6 years ago by Jun Omae

Summary: WindowsError: 5 ƒAƒNƒZƒX‚ª‹‘”Û‚³‚ê‚Ü‚µ‚½BWindowsError: (5, 'Access is denied')

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.