Modify

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#12616 closed defect (fixed)

Images causes OdtExport to Fail

Reported by: resathakanavci@… Owned by: Aurélien Bompard
Priority: normal Component: OdtExportPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I have a Trac installation with OdtExport plugin. Everything works OK, except images. When wiki page contains an image I have the attached error.

Attachments (1)

OdtExportError.PNG (109.5 KB) - added by resathakanavci@… 7 years ago.
Error screen

Download all attachments as: .zip

Change History (10)

Changed 7 years ago by resathakanavci@…

Attachment: OdtExportError.PNG added

Error screen

comment:1 Changed 7 years ago by Ryan J Ollos

Does the image filename have any non-ascii characters?

comment:2 Changed 6 years ago by Ryan J Ollos

In 15139:

0.7dev: Switch from PIL to pillow

  • Remove tag_svn_revision from setup.cfg since it's

unsupported in setuptools >= 10.

  • Correct protocol for trac-hacks.org.

Refs #12616.

comment:3 Changed 6 years ago by Ryan J Ollos

In 15140:

0.7dev: Add dependency link for uTidylib

Refs #12616.

comment:4 Changed 6 years ago by Ryan J Ollos

In 15141:

0.7dev: Remove support for PIL

Only pillow is supported after [15139].

Refs #12616.

comment:5 Changed 6 years ago by Ryan J Ollos

In 15142:

0.7dev: Use pytidylib libary instead of uTidyLib

Refs #12616.

comment:6 Changed 6 years ago by Ryan J Ollos

In 15143:

0.7dev: Require Trac >= 0.11

Refs #12616.

comment:7 Changed 6 years ago by Ryan J Ollos

In 15144:

0.7dev: Fix module has no attribute Image

This is a regression in [15141].

Refs #12616.

comment:8 Changed 6 years ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

In 15145:

0.7dev: Encode attachment path at utf-8

This should resolve UnicodeDecodeErrors when exporting
documents with attachments.

Fixes #12616.

comment:9 Changed 6 years ago by Ryan J Ollos

In 15146:

0.7dev: Fix missing attachment error for filenames with whitespace

Refs #12616.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Aurélien Bompard.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.