Modify

Opened 6 years ago

Closed 6 years ago

#12655 closed defect (duplicate)

AttributeError: 'NoneType' object has no attribute 'realm'

Reported by: Ryan J Ollos Owned by: Ryan J Ollos
Priority: normal Component: VotePlugin
Severity: normal Keywords:
Cc: Steffen Hoffmann Trac Release:

Description

[pid 7078 140573412062976] 2016-01-31 05:32:28,395 Trac[main] ERROR: Internal Server Error: <RequestWithSession "GET '/attachment/ticket/3990/TicketQueryMacroAddTimestampFormatting.diff'">, referrer 'http://trac.edgewall.org/ticket/3990'
Traceback (most recent call last):
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/trac/web/main.py", line 607, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/trac/web/main.py", line 266, in dispatch
    self._post_process_request(req, *resp)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/trac/web/main.py", line 441, in _post_process_request
    resp = f.post_process_request(req, *resp[:-1])
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/tracvote/__init__.py", line 396, in post_process_request
    resource = resource_from_path(self.env, req.path_info)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/tracvote/__init__.py", line 95, in resource_from_path
    if _resource_exists(env, resource) in (None, True):
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/tracvote/__init__.py", line 76, in _resource_exists
    return resource_exists(env, resource)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/trac/resource.py", line 468, in resource_exists
    return manager.resource_exists(resource)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/trac/attachment.py", line 380, in resource_exists
    attachment = Attachment(self.env, resource)
  File "/usr/local/virtualenv/1.1dev/lib/python2.7/site-packages/trac/attachment.py", line 661, in __init__
    self.parent_realm = resource.parent.realm
AttributeError: 'NoneType' object has no attribute 'realm'

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Looks like a duplicate of #12595.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.