Modify

Opened 22 months ago

Closed 9 months ago

Last modified 9 months ago

#12670 closed defect (fixed)

Does not work with SubcomponentsPlugin

Reported by: komar@… Owned by: komar@…
Priority: normal Component: TracTicketTemplatePlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description (last modified by Ryan J Ollos)

Tempate do no store component when SubcomponentsPlugin is installed.

Attachments (1)

support-subcomponent-plugin.patch (619 bytes) - added by komar@… 22 months ago.
patch for TracTicketTemplatePlugin to support SubcomponentsPlugin

Download all attachments as: .zip

Change History (11)

comment:1 Changed 22 months ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 22 months ago by Ryan J Ollos

It would be good if we can narrow down the source of the issue. Are there any JavaScript errors in the browser console?

comment:3 Changed 22 months ago by Ryan J Ollos

Description: modified (diff)
Summary: Do not work with SubcomponentsPluginDoes not work with SubcomponentsPlugin

comment:4 Changed 22 months ago by komar@…

No JavaScripts error. I choose to store in template "Component" "GNOME" and subcomponent "Control". After template applying I have in "Component" my default component "am", but not "GNOME/Control".

comment:5 Changed 22 months ago by Ryan J Ollos

I guess we shouldn't be surprised the plugins don't work together. Currently there's no one maintaining this plugin, so the issue is unlikely to be resolved unless someone provides a patch.

comment:6 Changed 22 months ago by komar@…

I check out database, it's stored right, as "GNOME/Control". Problem when template applyed

Changed 22 months ago by komar@…

comment:7 Changed 22 months ago by komar@…

I add patch what works for me

comment:8 Changed 9 months ago by Ryan J Ollos

Owner: changed from Richard Liao to Ryan J Ollos
Status: newaccepted

comment:9 Changed 9 months ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 16409:

1.0dev: Support SubcomponentsPlugin

Patch by komar@evologics.de.

Fixes #12670.

comment:10 Changed 9 months ago by Ryan J Ollos

Owner: changed from Ryan J Ollos to komar@…

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain komar@….
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.