Modify

Opened 16 months ago

Closed 8 months ago

Last modified 8 months ago

#12715 closed defect (fixed)

AttributeError: 'RepositoryManager' object has no attribute 'repository_dir'

Reported by: admin Owned by: Jun Omae
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description

How to Reproduce

While doing a GET operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'accounts', 'panel_id': u'users', 'path_info': None}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

System Information

Trac 1.1.6
Babel 2.2.0
Docutils 0.12
Genshi 0.7 (without speedups)
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 2.1.3
pysqlite 2.6.0
Python 2.7.4 (default, Apr 6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]
pytz 2016.3
setuptools 20.3.1
SQLite 3.6.21
jQuery 1.8.3
jQuery UI 1.9.2
jQuery Timepicker 1.1.1

Enabled Plugins

tracaccountmanager 0.4.4

Interface Customization

shared-htdocs
shared-templates
site-htdocs VGPE.png, game.png, logo.png, pic, theme.css, theme.css3
site-templates

Python Traceback

Traceback (most recent call last):
  File "C:\Python27\lib\site-packages\trac\web\main.py", line 587, in _dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python27\lib\site-packages\trac\web\main.py", line 246, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python27\lib\site-packages\trac\admin\web_ui.py", line 108, in process_request
    provider.render_admin_panel(req, cat_id, panel_id, path_info)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 204, in render_admin_panel
    return self._do_users(req)
  File "build\bdist.win32\egg\acct_mgr\admin.py", line 305, in _do_users
    acctmod = AccountModule(env)
  File "C:\Python27\lib\site-packages\trac\core.py", line 144, in __call__
    self.__init__()
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 73, in __init__
    self._write_check(log=True)
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 76, in _write_check
    writable = self.acctmgr.get_all_supporting_stores('set_password')
  File "build\bdist.win32\egg\acct_mgr\api.py", line 324, in get_all_supporting_stores
    for store in self.password_store:
  File "build\bdist.win32\egg\acct_mgr\api.py", line 296, in password_store
    for store in self.stores:
  File "C:\Python27\lib\site-packages\trac\core.py", line 82, in extensions
    components = [component.compmgr[cls] for cls in classes]
  File "C:\Python27\lib\site-packages\trac\core.py", line 208, in __getitem__
    component = cls(self)
  File "C:\Python27\lib\site-packages\trac\core.py", line 144, in __call__
    self.__init__()
  File "build\bdist.win32\egg\acct_mgr\svnserve.py", line 32, in __init__
    repo_dir = RepositoryManager(self.env).repository_dir
AttributeError: 'RepositoryManager' object has no attribute 'repository_dir'

Attachments (1)

t12715.diff (2.9 KB) - added by Jun Omae 8 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 16 months ago by Jun Omae

Trac Release: 1.2

comment:2 Changed 15 months ago by anonymous

Same error in trac 1.1.6 on deploy command

2016-04-21 16:23:46,141 Trac[main] ERROR: Internal Server Error: 
Traceback (most recent call last):
  File "D:\sapr\webserver\Python\lib\site-packages\trac\web\main.py", line 587, in _dispatch_request
    dispatcher.dispatch(req)
  File "D:\sapr\webserver\Python\lib\site-packages\trac\web\main.py", line 201, in dispatch
    for handler in self._request_handlers.values():
  File "D:\sapr\webserver\Python\lib\site-packages\trac\util\__init__.py", line 1175, in __get__
    result = self.fn(instance)
  File "D:\sapr\webserver\Python\lib\site-packages\trac\web\main.py", line 296, in _request_handlers
    for handler in self.handlers)
  File "D:\sapr\webserver\Python\lib\site-packages\trac\core.py", line 82, in extensions
    components = [component.compmgr[cls] for cls in classes]
  File "D:\sapr\webserver\Python\lib\site-packages\trac\core.py", line 208, in __getitem__
    component = cls(self)
  File "D:\sapr\webserver\Python\lib\site-packages\trac\core.py", line 144, in __call__
    self.__init__()
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 76, in __init__
    self._write_check(log=True)
  File "build\bdist.win32\egg\acct_mgr\web_ui.py", line 80, in _write_check
    writable = self.acctmgr.get_all_supporting_stores('set_password')
  File "build\bdist.win32\egg\acct_mgr\api.py", line 348, in get_all_supporting_stores
    for store in self.password_stores:
  File "D:\sapr\webserver\Python\lib\site-packages\trac\config.py", line 861, in __get__
    for impl in self.xtnpt.extensions(instance):
  File "D:\sapr\webserver\Python\lib\site-packages\trac\core.py", line 82, in extensions
    components = [component.compmgr[cls] for cls in classes]
  File "D:\sapr\webserver\Python\lib\site-packages\trac\core.py", line 208, in __getitem__
    component = cls(self)
  File "D:\sapr\webserver\Python\lib\site-packages\trac\core.py", line 144, in __call__
    self.__init__()
  File "build\bdist.win32\egg\acct_mgr\svnserve.py", line 32, in __init__
    repo_dir = RepositoryManager(self.env).repository_dir
AttributeError: 'RepositoryManager' object has no attribute 'repository_dir'

comment:3 Changed 15 months ago by Ryan J Ollos

Plugin does not yet support 1.1.x. There are numerous issues that need to be fixed.

comment:4 in reply to:  3 Changed 15 months ago by anonymous

Replying to rjollos:

Plugin does not yet support 1.1.x. There are numerous issues that need to be fixed.

from AccountManagerPlugin#Installation

Which version is best for you? Likely the stable release. It works for any release starting from Trac 0.11 to 1.1.x.

comment:6 Changed 9 months ago by anonymous

Just did a test upgrade to trac 1.2 ... and got this error so I stay with trac 1.0.13

I use python 2.7.12 (32bit) on win7 64 bit

comment:7 Changed 8 months ago by anonymous

Any idea when it will support trac 1.2 ?

Since this plugin is so useful we rely on it, I think this should be part of trac :-)

So for now we stay with trac 1.0

comment:8 in reply to:  7 Changed 8 months ago by Jun Omae

Replying to anonymous:

Any idea when it will support trac 1.2 ? [...] So for now we stay with trac 1.0

See comment:33:ticket:11915.

Last edited 8 months ago by Jun Omae (previous) (diff)

Changed 8 months ago by Jun Omae

Attachment: t12715.diff added

comment:9 Changed 8 months ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

In 16055:

0.5dev: Replace use of RepositoryManager.repository_dir in svnserve

The attribute has been removed in Trac 1.2.

Patch by Jun Omae.

Fixes #12715.

comment:10 Changed 8 months ago by Ryan J Ollos

Owner: changed from Steffen Hoffmann to Jun Omae

comment:11 Changed 8 months ago by Ryan J Ollos

Changes were manually tested. I intend to revisit this ticket later to add test coverage.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.