Modify

Opened 6 years ago

Closed 6 years ago

#12716 closed defect (duplicate)

AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Reported by: admin Owned by: Ryan J Ollos
Priority: normal Component: DownloadsPlugin
Severity: major Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a GET operation on /downloads, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

System Information

Trac 1.1.6
Babel 2.2.0
Docutils 0.12
FullBlog 0.1.5
Genshi 0.7 (without speedups)
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 2.6.0
Python 2.7.4 (default, Apr 6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]
pytz 2016.3
setuptools 20.3.1
SQLite 3.6.21
Subversion 1.7.9 (r1462340)
jQuery 1.8.3
jQuery UI 1.9.2
jQuery Timepicker 1.1.1

Enabled Plugins

pdfredirector 0.4
svnsyncplugin 0.1.2
tracdownloads 0.3dev-r0
tracfullblogplugin 0.1.5

Interface Customization

shared-htdocs
shared-templates
site-htdocs VGPE.png, game.png, logo.png, pic, theme.css, theme.css3
site-templates

Python Traceback

Traceback (most recent call last):
  File "build\bdist.win32\egg\trac\web\main.py", line 587, in _dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win32\egg\trac\web\main.py", line 246, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\tracdownloads\core.py", line 140, in process_request
    return api.process_downloads(context) + (None,)
  File "build\bdist.win32\egg\tracdownloads\api.py", line 341, in process_downloads
    db = self.env.get_db_cnx()
AttributeError: 'Environment' object has no attribute 'get_db_cnx'

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by anonymous

trac upgrade 1.1.6 version,this is multiple plugins not use

comment:2 Changed 6 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #12479.

Also, Trac 1.1.x is a development releases. We recommend Trac 1.0.x.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.