Modify

Opened 6 years ago

Closed 6 years ago

#12861 closed defect (duplicate)

error on building due to "SyntaxError: keyword argument repeated"

Reported by: shunichi.goto@… Owned by:
Priority: low Component: TracReleasePlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

Using recent version (r12643), Running python setup.py build causes error due to "SyntaxError: keyword argument repeated". Actually, setup() argument has two packages keyword entry In setup.py.

One of them should be removed:

  • setup.py

    diff -r 9610b82f807c setup.py
    a b  
    1212
    1313setup(name='TracReleasePlugin',
    1414        version='0.2',
    15         packages = ['tracrelease', 'tracrelease.db'],
    1615        description="Release Control",
    1716        author='Joao Alexandre de Toledo',
    1817        author_email='tracrelease@toledosp.com.br',

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

Thanks for the reporting. I noticed that is a duplicate of #4618....

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.