Modify

Opened 6 weeks ago

Closed 6 weeks ago

#12982 closed defect (duplicate)

trac 1.2 compatability, get_db_cnx depreciated

Reported by: anonymous Owned by:
Priority: normal Component: AnnouncerPlugin
Severity: critical Keywords:
Cc: Trac Release: 1.2

Description

The file at attachment:announcerplugin-trunk_r16059-get_db_cnx.patch contains a patch to trunk to bring the announcerplugin in line with tra 1.2. I'm not clear if this change is backwards compatible, likely not since I've noticed other plugins seem to maintain a separate branch for trac 1.2 compatibility.

Attachments (1)

announcerplugin-trunk_r16059-get_db_cnx.patch (3.1 KB) - added by kirk@… 6 weeks ago.
patch to make announcerplugin work with trac 1.2

Download all attachments as: .zip

Change History (2)

Changed 6 weeks ago by kirk@…

patch to make announcerplugin work with trac 1.2

comment:1 Changed 6 weeks ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12120. Also, you can only use get_read_db when the query contains selects. See TracDev/DatabaseApi#Trac1.0API.

The plugin will need many modifications for Trac 1.2, as outlined in #12120. Parts of the plugin have been integrated into Trac 1.2, as described in TracDev/Proposals/AdvancedNotification.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.