Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#13191 closed defect (fixed)

Triage does not support the Ticket Create Action in Trac 1.2

Reported by: Cauly Owned by: Ryan J Ollos
Priority: normal Component: AdvancedTicketWorkflowPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description

When using ticket create action in 1.2 with triage, there will be an error when rendering newticket page.

ini file:

create_ticket = <none> -> *
create_ticket.name = create
create_ticket.operations = triage
create_ticket.triage_field = type
create_ticket.triage_split = a -> StateA

This will produce:

File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/trac/web/main.py", line 623, in _dispatch_request
  dispatcher.dispatch(req)
File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/trac/web/main.py", line 239, in dispatch
  resp = chosen_handler.process_request(req)
File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/trac/ticket/web_ui.py", line 178, in process_request
  return self._process_newticket_request(req)
File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/trac/ticket/web_ui.py", line 531, in _process_newticket_request
  self._get_action_controls(req, ticket)
File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/trac/ticket/web_ui.py", line 453, in _get_action_controls
  req, ticket, action)
File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/advancedworkflow/controller.py", line 351, in render_ticket_action_control
  new_status = self._new_status(ticket, action)
File "/Users/cauly/Documents/workspace/projects/ProjectPenguin2Server/env/lib/python2.7/site-packages/advancedworkflow/controller.py", line 371, in _new_status
  if value == ticket[field].strip():
AttributeError: 'NoneType' object has no attribute 'strip'

I think it's because the ticket's type is None when a ticket is initialized.

Attachments (0)

Change History (4)

comment:1 Changed 7 months ago by Ryan J Ollos

Owner: changed from Eli Carter to Ryan J Ollos
Status: newaccepted

comment:2 Changed 7 months ago by Ryan J Ollos

I can't reproduce the traceback, but you appear to be running an older version of the 1.2 branch. I'll commit some minor fixes. See also #12823.

comment:3 Changed 7 months ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 16620:

TracAdvancedTicketWorkflow 1.2.1dev: Fix workflow hint for triage op

Fixes #13191.

comment:4 Changed 7 months ago by Cauly

Thank You for the reply!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.