Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#13234 closed defect (fixed)

[PATCH] Default to leaving ticket owner unchanged rather than taking ownership

Reported by: Jon Ashley Owned by: Jon Ashley
Priority: normal Component: FlexibleAssignToPlugin
Severity: minor Keywords:
Cc: Trac Release: 1.0

Description (last modified by Jon Ashley)

The FlexibleAssignToPlugin pre-selects the name of the authenticated user who is viewing the ticket into the select controls that are managed by the plugin. This means that the default behaviour is for the user to take ownership of a ticket on a ticket update.

The comment at line 198 of the main source file states "Check to see if the current owner is in the list of valid owners; if so, pre-select them in the select control". This suggest that the intended default behaviour was to leave the current owner unchanged (which is why I've reported this as a defect rather than an enhancement).

Whether it was intended or not, I much prefer to have the select control pre-selected with the existing ticket owner, so that the user has to actively choose to take ownership. The attached patch is used in my local installation to achieve this. Without this patch, I find that users do quite a lot of taking ownership by accident.

Attachments (1)

flexibleassignto.diff (1.2 KB) - added by Jon Ashley 5 months ago.
Patch to flexibleassignto.py to keep ticket ownership unchanged by default

Download all attachments as: .zip

Change History (5)

Changed 5 months ago by Jon Ashley

Attachment: flexibleassignto.diff added

Patch to flexibleassignto.py to keep ticket ownership unchanged by default

comment:1 Changed 5 months ago by Jon Ashley

Description: modified (diff)

comment:2 Changed 5 months ago by Ryan J Ollos

Owner: set to Ryan J Ollos
Resolution: fixed
Status: newclosed

In 16703:

FlexibleAssignTo 0.8.13: Default to leaving ticket owner unchanged

Patch by ash.

Fixes #13234.

comment:3 Changed 5 months ago by Ryan J Ollos

Owner: changed from Ryan J Ollos to Jon Ashley

comment:4 Changed 5 months ago by Ryan J Ollos

I did some work to try and make this plugin unnecessary in Trac 1.3.2+. The plugin looked overly complex to me. In the future I'd be interested to know if there's a use-case for the plugin in Trac 1.3.2+ that can't be covered by the suggestions described at the top of the FlexibleAssignToPlugin page.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jon Ashley.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.