Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13265 closed defect (worksforme)

Support Trac 1.2.2 ???

Reported by: johnt888@… Owned by: Jun Omae
Priority: normal Component: TracWysiwygPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.2

Description

Hi -

I installed it,for Trac 1.2.2 and it's been enabled. But I can't see the "wysiwyg" when I edit the Wiki.

Thanks!

Attachments (4)

20170901T011453.png (10.8 KB) - added by Jun Omae 5 years ago.
20170901T011709.png (16.6 KB) - added by Jun Omae 5 years ago.
20170901T011727.png (22.4 KB) - added by Jun Omae 5 years ago.
20170901T012322.png (13.3 KB) - added by Jun Omae 5 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by Jun Omae

Resolution: worksforme
Status: newclosed

comment:2 Changed 5 years ago by johnt888@…

The issue is related to the combination of "DefaultCcPlugin" and "WysiwygPlugin". Both plugins work with Trac 1.0 though.

comment:3 Changed 5 years ago by Jun Omae

worksforme again.

I just verified and it works for me on Trac 1.2.2 with TracWysiwygPlugin and DefaultCcPlugin.

comment:4 Changed 5 years ago by Jun Omae

Also, I believe two plugins are not related.

Please reopen this ticket with error details in your javascript console if you encounter the issue on new Trac Environment with only TracWysiwygPlugin.

comment:5 Changed 5 years ago by johnt888@…

Resolution: worksforme
Status: closedreopened

There's no error ... Did you run "trac-admin upgrade" after installation of DefaultCC plugin? I can't see those "wysiwyg" button when I edit the Wiki page.

Thanks!

Changed 5 years ago by Jun Omae

Attachment: 20170901T011453.png added

Changed 5 years ago by Jun Omae

Attachment: 20170901T011709.png added

Changed 5 years ago by Jun Omae

Attachment: 20170901T011727.png added

comment:6 Changed 5 years ago by Jun Omae

Resolution: worksforme
Status: reopenedclosed

Works for me, again, again.

$ virtualenv /dev/shm/venv-trac-1.2.2
Using real prefix '/usr'
New python executable in /dev/shm/venv-trac-1.2.2/bin/python
Installing setuptools, pip, wheel...done.
$ /dev/shm/venv-trac-1.2.2/bin/pip install -q Trac==1.2.2
$ /dev/shm/venv-trac-1.2.2/bin/easy_install -qZ https://trac-hacks.org/svn/tracwysiwygplugin/0.12
$ /dev/shm/venv-trac-1.2.2/bin/easy_install -qZ https://trac-hacks.org/svn/defaultccplugin/trunk
$ /dev/shm/venv-trac-1.2.2/bin/pip list --format=columns
Package     Version
----------- --------
DefaultCc   0.4.dev0
Genshi      0.7
pip         9.0.1
setuptools  36.3.0
Trac        1.2.2
TracWysiwyg 0.12.0.7
wheel       0.29.0
$ /dev/shm/venv-trac-1.2.2/bin/trac-admin /dev/shm/tracenv-1.2 initenv 'My Project' sqlite:db/trac.db >/dev/null
$ /dev/shm/venv-trac-1.2.2/bin/trac-admin /dev/shm/tracenv-1.2 permission add authenticated TRAC_ADMIN
$ /dev/shm/venv-trac-1.2.2/bin/trac-admin /dev/shm/tracenv-1.2 config set components 'tracwysiwyg.*' enabled
$ /dev/shm/venv-trac-1.2.2/bin/trac-admin /dev/shm/tracenv-1.2 config set components 'defaultcc.*' enabled
$ /dev/shm/venv-trac-1.2.2/bin/trac-admin /dev/shm/tracenv-1.2 upgrade
Upgrade done.

You may want to upgrade the Trac documentation now by running:

  trac-admin "/dev/shm/tracenv-1.2" wiki upgrade

$ /dev/shm/venv-trac-1.2.2/bin/tracd -s -p 3000 --basic-auth *,$HOME/src/trac/htpasswd.txt,auth /dev/shm/tracenv-1.2
Server starting in PID 4601.
Serving on 0.0.0.0:3000 view at http://127.0.0.1:3000/
Using HTTP/1.1 protocol version
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /newticket HTTP/1.1" 200 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/common/css/trac.css HTTP/1.1" 304 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/common/css/ticket.css HTTP/1.1" 304 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/common/css/jquery-ui-addons.css HTTP/1.1" 304 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/common/css/jquery-ui/jquery-ui.css HTTP/1.1" 304 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/tracwysiwyg/wysiwyg.css HTTP/1.1" 304 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/common/js/jquery.js HTTP/1.1" 304 -
192.168.11.36 - - [01/Sep/2017 01:16:46] "GET /chrome/common/js/babel.js HTTP/1.1" 304 -
...

comment:7 Changed 5 years ago by Jun Omae

You should post how to reproduce it.

Changed 5 years ago by Jun Omae

Attachment: 20170901T012322.png added

comment:8 Changed 5 years ago by Jun Omae

Of course, wysiwyg feature is available in wiki editing as well.

comment:9 Changed 5 years ago by Jun Omae

That's an installation issue. Please ask on trac-user mailing list.

comment:10 Changed 5 years ago by anonymous

Ok, I checked it again. A brand new database from 1.2.2 works with both plugins. I will check the existing one and report back if I have more findings.

thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.