Modify

Opened 2 months ago

Closed 2 months ago

#13294 closed defect (fixed)

Build error with Python 2.7.6 but not with 2.7.13

Reported by: ntmlod Owned by: Ryan J Ollos
Priority: low Component: FieldTooltipPlugin
Severity: minor Keywords:
Cc: Trac Release: 1.0

Description

Well probably nothing really serious, I didn't succeed to compile the egg file in our server with the error

error: can't copy 'fieldtooltip/htdocs/jquerytooltip': doesn't exist or not a regular file

On my laptop, I build the egg, copy it to the server and run it without issue.

The noticeable difference between the 2 is the version of Python (2.7.13 instead of 2.7.6).

Attachments (0)

Change History (6)

comment:1 Changed 2 months ago by Ryan J Ollos

It's more likely that the version of setuptools or another environment issue is the significant difference.

What version of setuptools do you have on the server?

comment:2 Changed 2 months ago by Ryan J Ollos

Owner: changed from Matoba Akihiro to Ryan J Ollos
Status: newaccepted

comment:3 Changed 2 months ago by ntmlod

Only 1.3 on the server, I certainly can upgrade it locally in the project environment to avoid similar issue in the future.

What is the minimal version recommended now ? I will see if I can build it.

comment:4 Changed 2 months ago by Ryan J Ollos

Minimum recommended version is usually 0.6. You should avoid 5.4 through 5.6. I'll see if I can reproduce with version 1.3.

comment:5 Changed 2 months ago by Ryan J Ollos

I can reproduce, but the issue doesn't occur with the latest setuptools (36.5.0). The issue is seen with setuptools 20.0, but not 30.0. I didn't search any further for the exact version in which the issue is resolved.

Fix is described in SO:3712682/121694.

comment:6 Changed 2 months ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 16858:

FieldTooltip 0.7.3: Fix error including package data

Fixes #13294.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.