Modify

#13467 closed defect (fixed)

automatic line break is missing between keywords

Reported by: c.feige@… Owned by: Ryan J Ollos
Priority: normal Component: TracKeywordsPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

Problem:

The browser does not perform automatic line break between keywords, which will cause the keyword list and the fieldset container to overflow on the right hand side of the screen. One would rather expect that the list of keywords would break and continue on the next line.

Setup:

I am using

Reproduce:

Easy to reproduce. Create a very long keyword list preferably with very long keyword names.

Analyis:

I was able to trace this down to the trac_keywords.js which actually build dynamically the keyword list. (In fact it is not a real <ol> itemization list, just a bunch of a<> anchor elements). I believe the easiest solution would be if the trac_keywords.js would insert a space or carriage return between the a<> anchor elements, this should allow automatic line breaks. As of today no spaces are there:

<a>...</a><a>...</a><a>...</a>

Better insert spaces:

<a>...</a> <a>...</a> <a>...</a>

or even carriage return:

<a>...</a>
<a>...</a>
<a>...</a>

Unfortunately I am unable to provide a patch because my knowledge about Java Script and jQuery is rather limited.

Thanks Clemens

Attachments (0)

Change History (2)

comment:1 Changed 13 months ago by Ryan J Ollos

Owner: set to Ryan J Ollos
Status: newaccepted

comment:2 Changed 13 months ago by Ryan J Ollos

Resolution: fixed
Status: acceptedclosed

In 17252:

TracKeywordsPlugin 1.0dev: Wrap keywords in fieldset

Fixes #13467.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.