Modify

Opened 20 months ago

Closed 20 months ago

Last modified 5 months ago

#13610 closed defect (duplicate)

AccountManager doesn't works on Trac-1.4

Reported by: thanatermesis@… Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords:
Cc: Trac Release: 1.4

Description

Trying to install AccountManager on a recent Trac-1.4 gives me these errors:

Trac[loader] ERROR: Skipping "acct_mgr.admin = acct_mgr.admin": ImportError: cannot import name NotifyEmail
Trac[loader] ERROR: Skipping "acct_mgr.macros = acct_mgr.macros": ImportError: cannot import name NotifyEmail
Trac[loader] ERROR: Skipping "acct_mgr.notification = acct_mgr.notification": ImportError: cannot import name NotifyEmail
Trac[loader] ERROR: Skipping "acct_mgr.register = acct_mgr.register": ImportError: cannot import name NotifyEmail
Trac[loader] ERROR: Skipping "acct_mgr.web_ui = acct_mgr.web_ui": ImportError: cannot import name NotifyEmail

Attachments (0)

Change History (10)

comment:1 Changed 20 months ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #13124 and fixed in r17492.

Please install 0.6dev from accountmanagerplugin/trunk and give feedback if you can. I'll release 0.6 if we get feedback on those changes, and check there are no other issues with Trac 1.4.

comment:2 Changed 20 months ago by anonymous

Hello Ryan,

When trying to configure 1.4, I already tried to install the last version available, my command was:

easy_install https://trac-hacks.org/svn/accountmanagerplugin/trunk

and looking at the "lib" directory it said 0.6 too, but the errors where the same, I was unable to use it

I cannot test it again because I finally decided to switch back to the version Trac-1.2.5 which finally worked without problems, but that's what I remember from my experience trying to make it working

Is there somebody that was able to make it working on the version 1.4? (seems like 1.3 gave the same errors)

comment:3 in reply to:  2 Changed 20 months ago by Ryan J Ollos

Replying to anonymous:

and looking at the "lib" directory it said 0.6 too, but the errors where the same, I was unable to use it

NotifyEmail is not used after r17492, so your Trac must still be loading the older version of the plugin when you saw those errors.

You can try uninstall/install the plugin using pip. I've recently updated the documentation:

Is there somebody that was able to make it working on the version 1.4? (seems like 1.3 gave the same errors)

Yes, I did some testing after #13124 and it seemed to be working.

comment:4 Changed 16 months ago by tonikasch

Hi,

Trac 1.4 + TracAccountManager-0.6.dev0

Installed via: # pip install svn+https://trac-hacks.org/svn/accountmanagerplugin/trunk

However, html login was not working so finally chose the .htpasswd method (using wscgi script, and pymysql instead of mysql connector (now deprecated)).

Regards

Version 0, edited 16 months ago by tonikasch (next)

comment:5 in reply to:  4 Changed 15 months ago by Ryan J Ollos

Replying to tonikasch:

However, html login was not working so finally chose the .htpasswd method (using wscgi script, and pymysql instead of mysql connector (now deprecated)).

Would need to see your [accountmanager] section to investigate further. Also, please check the logs.

comment:6 in reply to:  4 Changed 12 months ago by Mike B

Using Trac 1.4.1 on a Digital Ocean Ubuntu 18.04 server.. Upgrading TracAcctMgr to trunk (currently 0.6) solved the login problem.

I enabled DEBUG-level logging and was able to see AcctMgr NOT loading because it was trying to find a class NotifyEmail, that does not exist.

It seems the dependency on NotifyEmail has been removed in the current trunk branch - thanks for the solution, let's make it official!

comment:7 Changed 8 months ago by anonymous

Hi

Trac 1.5.1 + TracAccountManager-0.6.dev0

pip install https://trac-hacks.org/browser/accountmanagerplugin/trunk?format=zip

Conf:

acct_mgr.admin.* = enabled
acct_mgr.api.* = enabled
acct_mgr.db.sessionstore = disabled
acct_mgr.htfile.htdigeststore = disabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.http.* = disabled
acct_mgr.notification.* = disabled
acct_mgr.pwhash.* = disabled
acct_mgr.register.* = enabled
acct_mgr.svnserve.svnservepasswordstore = disabled
acct_mgr.web_ui.* = enabled
acct_mgr.web_ui.resetpwstore = disabled
trac.web.auth.loginmodule = enabled
acct_mgr.register.* = disabled

Error happens:

AttributeError: 'NoneType' object has no attribute 'setdefault'

Log:

2020-09-09 14:43:30,223 Trac[main] ERROR: [::1] Internal Server Error: <RequestWithSession "GET '/admin/accounts/users'">, referrer 'http://localhost/trac/timefiler/admin/general/plugin'
Traceback (most recent call last):
  File "build\bdist.win-amd64\egg\trac\web\main.py", line 612, in dispatch_request
    dispatcher.dispatch(req)
  File "build\bdist.win-amd64\egg\trac\web\main.py", line 264, in dispatch
    metadata.setdefault('iterable', chrome.use_chunked_encoding)
AttributeError: 'NoneType' object has no attribute 'setdefault'

comment:8 Changed 5 months ago by rhills@…

Hi,

Trac 1.4.2 here + TracAccountManager-0.6.dev0 installed via:

pip install https://trac-hacks.org/browser/accountmanagerplugin/trunk?format=zip

Login link appears on menu, but when I click it I get:

Trac[chrome] ERROR: Genshi template (account_login.html) detected but Genshi is not installed

Is this a legacy template or incomplete dependency?

Cheers,

Rob Hills Waikiki, Western Australia

comment:9 in reply to:  8 Changed 5 months ago by anonymous

Replying to rhills@…:

For the record, this was fixed by installing Genshi (genshi-0.7.5):

pip install genshi

Cheers,

Rob Hills Waikiki, Western Australia

comment:10 Changed 5 months ago by Ryan J Ollos

In 17941:

TracAccountManager 0.6dev: Add Genshi to installation requirements

Refs #13610.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.