Modify

Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#14177 closed defect (duplicate)

Account Panel not shown in Trac 1.4.3 + TracAccount Manager 0.5.0

Reported by: anonymous Owned by: Ryan J Ollos
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.4

Description

Hello,

I'm trying to switch Trac 1.0 to 1.4.3. So far, I'm not able to get the account panel.
Any suggestion?

In Trac 1.0, things are all right.

Thanks and best regards, Kazunari Sekigawa

Attachments (5)

T267-75.png (100.5 KB) - added by anonymous 14 months ago.
T267-76.png (103.7 KB) - added by anonymous 14 months ago.
trac.zip (6.0 KB) - added by anonymous 14 months ago.
T267-77.png (143.7 KB) - added by anonymous 14 months ago.
T267-78.png (134.8 KB) - added by anonymous 14 months ago.

Download all attachments as: .zip

Change History (11)

Changed 14 months ago by anonymous

Attachment: T267-75.png added

Changed 14 months ago by anonymous

Attachment: T267-76.png added

comment:1 Changed 14 months ago by Jun Omae

Could you please provide trac.log file when visiting admin panel with DEBUG level? See BugReporting#CollectingDebugMessages about the logging.

comment:2 Changed 14 months ago by anonymous

Thanks for your reply.
I have collected the log messages ===> trac.zip

Additional info is as follows:

[1] TracAccountManager 0.5.0: built from the source
    $HOST{$USER}(1)$ svn info
    Path: .
    URL: https://trac-hacks.org/svn/accountmanagerplugin/tags/acct_mgr-0.5.0
    Relative URL: ^/accountmanagerplugin/tags/acct_mgr-0.5.0
    Repository Root: https://trac-hacks.org/svn
    Revision: 18497
    Node Kind: directory
    Schedule: normal
    Last Changed Author: rjollos
    Last Changed Rev: 17216
    Last Changed Date: 2018-06-21 11:18:05 +0900

[2] Trac: 1.4.3  built from the source "Trac-1.4.3.tar.gz"
          (https://trac.edgewall.org/wiki/TracDownload#Trac14StableRelease)

[3] Server: Server version: Apache/2.4.41 (Ubuntu) + mod_wsgi 4.6.8

[4] Database: sqlite 3.31.1 + pysqlite 2.7.0

[5] OS: Linux $HOST 5.4.0-137-generic #154-Ubuntu SMP Thu Jan 5 17:03:22 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Kind regards,
Kazunari Sekigawa

Changed 14 months ago by anonymous

Attachment: trac.zip added

comment:3 Changed 14 months ago by Jun Omae

Thanks for the feedback.

AccountManagerPlugin 0.5.0 doesn't work with Trac 1.4.x due to the following ImportErrors. Instead, please try https://trac-hacks.org/svn/accountmanagerplugin/branches/acct_mgr-0.5.

2023-01-16 08:25:42,286 Trac[loader] ERROR: Skipping "acct_mgr.admin = acct_mgr.admin": ImportError: cannot import name NotifyEmail
2023-01-16 08:25:42,290 Trac[loader] ERROR: Skipping "acct_mgr.macros = acct_mgr.macros": ImportError: cannot import name NotifyEmail
2023-01-16 08:25:42,291 Trac[loader] ERROR: Skipping "acct_mgr.notification = acct_mgr.notification": ImportError: cannot import name NotifyEmail
2023-01-16 08:25:42,360 Trac[loader] ERROR: Skipping "acct_mgr.register = acct_mgr.register": ImportError: cannot import name NotifyEmail
2023-01-16 08:25:42,362 Trac[loader] ERROR: Skipping "acct_mgr.web_ui = acct_mgr.web_ui": ImportError: cannot import name NotifyEmail

comment:4 Changed 14 months ago by Jun Omae

I noticed the same issue has been reported and fixed in #13610.

If the branches/acct_mgr-0.5 doesn't work, try https://trac-hacks.org/svn/accountmanagerplugin/trunk/ (0.6dev) rather than.

Changed 14 months ago by anonymous

Attachment: T267-77.png added

Changed 14 months ago by anonymous

Attachment: T267-78.png added

comment:5 Changed 14 months ago by anonymous

Thanks a lot for your prompt response and instructions.
As shown in the attached image, I could resolve this issue with the 0.6 version.
So, please close this ticket.



Once again, thank you very much.
Kazunari Sekigawa

comment:6 Changed 14 months ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #13610.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.