Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13775 closed defect (fixed)

Base usage of the ChildTicketTree macro call fails

Reported by: ahowell82@… Owned by: ahowell82@…
Priority: normal Component: ChildTicketTreeMacro
Severity: normal Keywords:
Cc: Trac Release:

Description

While attempting to utilize this plugin, I used [[ChildTicketTree]] in a comment & a wiki text area, I received the following error:

Error: Macro ChildTicketTree(None) failed
operator does not exist: text = integer
LINE 2:                      FROM wiki WHERE name=490 ORDER BY versi...
                                                 ^
HINT:  No operator matches the given name and argument type(s). You might need to add explicit type casts.

Attachments (0)

Change History (5)

comment:1 Changed 2 years ago by ahowell82@…

Looks like the issue is line 45 of macro.py

kwargs['ticket'] = WikiPage(self.env, resource).name

The issue is the WikiPage is not the method to get the ticket when the ticket number is not referenced ... use the below ... I am not sure what additional possible impacts may exist

kwargs['ticket'] = resource.id

comment:2 Changed 2 years ago by Ryan J Ollos

Resolution: fixed
Status: newclosed

In 17688:

Tracchildtickettreemacro 1.1.1: Fix usage with ticket id as first arg

Fixes #13775.

comment:3 Changed 2 years ago by Ryan J Ollos

Owner: changed from Mark Ryan to ahowell82@…

comment:4 Changed 2 years ago by Ryan J Ollos

In 17689:

Tracchildtickettreemacro 1.1.1: Fix mispelled import

Refs #13775.

comment:5 Changed 2 years ago by anonymous

Awesome response time! I have installed the new version & can confirm that the plugin works wonderfully

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ahowell82@….
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.