Modify

Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#1749 closed enhancement (fixed)

[Patch] 0.11 support for TicketDeletePlugin

Reported by: phpxcache Owned by: Jeroen Ruigrok van der Werven
Priority: normal Component: TicketDeletePlugin
Severity: blocker Keywords:
Cc: Benoit Grégoire, Daniel Atallah, Marcus Lindblom, listman@… Trac Release: 0.11

Description

0.11 support for deleteticket

Attachments (7)

ticketdelete-trac0.11.patch (13.3 KB) - added by phpxcache 10 years ago.
ticketdelete-trac0.11-v2.patch (13.3 KB) - added by Pedro Algarvio, aka, s0undt3ch 10 years ago.
Actual patch from svn, no copy/paste
ticketdelete-trac0.11-v3.patch (12.6 KB) - added by Harri Kaimio 9 years ago.
new version, tested with trac 0.11 r6202
ticketdelete-trac0.11-v4.patch (7.4 KB) - added by Magnus Johansson 9 years ago.
Patch tested against r3519
ticketdeleteplugin_timestamp_fix.patch (1.2 KB) - added by jonas@… 9 years ago.
Asmodai this appears to fix the timestamp issue on t.e.o we talked about yesterday
trac-0.11-okamototk.patch (8.0 KB) - added by anonymous 9 years ago.
patch for 0.11 by okamototk
ticketdeleteplugin_0.11_working.patch (62.1 KB) - added by daniel 9 years ago.
Patch to implement the button with a ITemplateStreamFilter and make the plugin work fully

Download all attachments as: .zip

Change History (42)

Changed 10 years ago by phpxcache

Attachment: ticketdelete-trac0.11.patch added

comment:1 Changed 10 years ago by phpxcache

Trac Release: 0.100.11

Changed 10 years ago by Pedro Algarvio, aka, s0undt3ch

Actual patch from svn, no copy/paste

comment:2 Changed 10 years ago by Pedro Algarvio, aka, s0undt3ch

I re-added the v2 patch because the first one was a copy/paste on a remote machine and might introduce apply problems.

comment:3 in reply to:  2 Changed 10 years ago by Pedro Algarvio, aka, s0undt3ch

Severity: normalblocker
Type: defectenhancement

Replying to s0undt3ch:

I re-added the v2 patch because the first one was a copy/paste on a remote machine and might introduce apply problems.

This version still fails to delete ticket changes, ie, it only works for deleting complete tickets.

Changed 9 years ago by Harri Kaimio

new version, tested with trac 0.11 r6202

comment:4 Changed 9 years ago by Harri Kaimio

New ersion of the patch that works with the current 0.11 tree.

comment:5 Changed 9 years ago by anonymous

i install deleteticket on trac 0.11 via

easy_install http://trac-hacks.org/svn/ticketdeleteplugin/0.11/

Installation Works but no menu on the Admin page and i have the following error on the log:

ERROR: Skipping "ticketdelete.web_ui = ticketdelete.web_ui": (can't import "No module named webadmin.web_ui")

Thanks for Helping

comment:6 Changed 9 years ago by ross

hkaimio,

even with your latest patch ticketdelete-trac0.11-v3.patch it still does not work on 0.11 for deleting ticket changes:

Trac detected an internal error: 
TypeError: object of type 'Undefined' has no len()


File "C:\Documents and Settings\LocalService\Application Data\Python-Eggs\tracticketdelete-2.0-py2.5.egg-tmp\ticketdelete\templates\ticketdelete_admin.html", line 34, in <Expression u'len(ticketdelete.changes)'> 

Would be great if someone puts the fully working TicketDeletePlugin for 0.11 It's really very useful.

comment:7 Changed 9 years ago by anonymous

Cc: Benoit Grégoire added; anonymous removed

comment:8 Changed 9 years ago by gregoryba@…

Cc: gregoryba@… added

there's a traceback of an error with 0.11 over at #2781, might or might not be related.

Changed 9 years ago by Magnus Johansson

Patch tested against r3519

comment:9 Changed 9 years ago by Magnus Johansson

I've attached a patch against r3519 that seem to be working fine with 0.11

The path also enables some attachment deletion, but use this with care. I haven't really tested this

comment:10 Changed 9 years ago by Jeroen Ruigrok van der Werven

Owner: changed from Noah Kantrowitz to Jeroen Ruigrok van der Werven
Status: newassigned

Committed patch v4 in r3526.

Changed 9 years ago by jonas@…

Asmodai this appears to fix the timestamp issue on t.e.o we talked about yesterday

comment:11 Changed 9 years ago by Jeroen Ruigrok van der Werven

Committed in r3542.

comment:12 Changed 9 years ago by Jeroen Ruigrok van der Werven

Err, make that r3543.

comment:13 Changed 9 years ago by anonymous

TicketDeletePlugin doesn't work yes.

I attached additional patch for 0.11(trac-0.11-okamototk.patch).

regards,

Takashi Okamoto

Changed 9 years ago by anonymous

Attachment: trac-0.11-okamototk.patch added

patch for 0.11 by okamototk

Changed 9 years ago by daniel

Patch to implement the button with a ITemplateStreamFilter and make the plugin work fully

comment:14 Changed 9 years ago by Daniel Atallah

I attached a patch which brings this plugin fully up to date with 0.11 as far as I can tell. Both the overall ticket deletion and the change deletion pages appear to work correctly, including linking from Delete buttons on the ticket screen.

I wish I had seen this ticket before starting working on this as it would have saved me some time.

Some of the changes I made in addition to the bug fixes:

  • The adding of the buttons has been updated to a ITemplateStreamFilter to !add them as the page is being rendered on the server instead of adding them with javascript. (thanks to aat for helping me figure out how to do this)
  • Make the "back" button link to the referrer screen instead of always the !admin screen

comment:15 Changed 9 years ago by Daniel Atallah

Cc: Daniel Atallah added

comment:16 in reply to:  14 Changed 8 years ago by Michael Renzmann

Replying to datallah:

I attached a patch which brings this plugin fully up to date with 0.11 as far as I can tell.

I can confirm that this patch works in combination with r3543.

comment:17 Changed 8 years ago by anonymous

Doesn't work with 0.11-stable (and Mastertickets?)

comment:18 in reply to:  17 Changed 8 years ago by Daniel Atallah

Replying to anonymous:

Doesn't work with 0.11-stable (and Mastertickets?)

What about it doesn't work?

comment:19 Changed 8 years ago by gregoryba@…

Cc: gregoryba@… removed

removed my cc.

comment:20 Changed 8 years ago by Ryan J Ollos

Hello, I am having a few problems with the plug-in in 0.11. These are described in ticket #996 and #5580. I've been looking at this thread and trying to figure out if all of the patches here have been committed to the 0.11 branch, but I'm a bit lost. Can someone tell me if the 0.11 branch is the 'best' working version with 0.11?

comment:21 Changed 8 years ago by Marcus Lindblom

Cc: Marcus Lindblom added

Add me to cc, has similar 0.11 problems.

comment:22 in reply to:  21 Changed 8 years ago by anonymous

Cc: listman@… added

Replying to marcusl:

Add me to cc, has similar 0.11 problems.

add me to please. this plugin seems to be broken in 0.11

comment:23 Changed 8 years ago by Jeff Hammel

can you see if this works with the 0.11 branch since r6812? its working on 0.11.5 here fine

comment:24 Changed 8 years ago by anonymous

Summary: 0.11 support for deleteticket[Patch] 0.11 support for TicketDeletePlugin

comment:25 Changed 7 years ago by Ryan J Ollos

See also #3649.

comment:26 Changed 7 years ago by Ryan J Ollos

See also #1114.

comment:27 Changed 6 years ago by johannes

Hi everybody,

I am having this problem: installed the ticket delete egg under 0.11b and the log is giving this:

2011-03-19 09:27:52,750 Trac[loader] ERROR: Skipping "ticketdelete.web_ui = ticketdelete.web_ui": (can't import "cannot import name add_notice")

Is this related to the fix you did here? If so how can I merge the svn-sources and the patch? I am working under WinXP and I downloaded the patch.exe from Gnu, but this is giving me the following as result:

#####output of win console######
C:\bla>c:\Programme\GnuWin32\bin\patch.exe -p0 -i ticketdeleteplugin_0.11_working.patch
patching file ticketdelete/web_ui.py
Assertion failed: hunk, file ../patch-2.5.9-src/patch.c, line 354

This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.

###### end console ###### can Ido it with svn merge, too?

Thanks for your help!

Best Regards, Johannes

comment:28 Changed 6 years ago by johannes

Hi all,

I just upgraded to 0.12

best J

comment:29 Changed 5 years ago by Matthijs Kooijman

I've been using ticketdelete with 0.11 for quite some time (years) now, so I guess this ticket is obsolete?

comment:30 Changed 5 years ago by Ryan J Ollos

#2781 closed as a duplicate.

comment:31 Changed 5 years ago by Ryan J Ollos

#6289 is closed as a duplicate, since switching to ITemplateStreamFilter implementation will certainly fix the issue.

comment:32 Changed 5 years ago by Ryan J Ollos

#2870 closed as a duplicate.

comment:33 Changed 5 years ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

(In [11802]) Refs #1749: (3.0.0dev) Applied patch by Daniel with modifications. Delete buttons are added in ITemplateStreamFilter.filter_stream rather than using JavaScript.

comment:34 Changed 5 years ago by Ryan J Ollos

Please create a new ticket for any issues found while testing r11802. Feedback is appreciated.

comment:35 Changed 5 years ago by Ryan J Ollos

[11802] should resolve #7113, #8572, #6442, #6289 and issues with any plugins that use JQuery or JavaScript.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jeroen Ruigrok van der Werven.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.