Opened 17 years ago

Closed 15 years ago

Last modified 15 years ago

#1800 closed defect (fixed)

No chart when clicking Burndown chart button.

Reported by: plafoucriere@… Owned by: daan
Priority: normal Component: ScrumBurndownPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11


I just installed the plugin, and it seems to work, except that I can't the charts working. I'm using trac 0.10.3 on a debian etch, with python 2.4.4 (debian's default) and ScrumBurndown plugin version 01.08.10 and TimeAndEstimationPlugin version

Installation went OK, and I have the buttons Management and Burndown in trac.

Thus, when I click on a milestone, and select the Start Milteston button, nothing happens. The database is updated (milestone table), but I can't see the Complete miltestone button. Moreover, The chart will never display.


Attachments (1)

Picture 3.png (21.1 KB) - added by plafoucriere@… 17 years ago.
broken chart

Download all attachments as: .zip

Change History (11)

Changed 17 years ago by plafoucriere@…

Attachment: Picture 3.png added

broken chart

comment:1 Changed 17 years ago by anonymous

Apparently, I still have to run the script every day, even if I'm using version 01.08.10. I thought this version was supposed to update automatically the graph.

I'm leaving the ticket open since this is not the expected process.

comment:2 Changed 16 years ago by cerw@…

So we still need to use cron? for each trac?

comment:3 Changed 16 years ago by robert@…

So, what's up with this one? I have the same problem. Notice from the image there is no Milestone Complete button either. What do we need to do?

Also, when I try running the script it says:

first run of today - insert needed

What does that mean? I notice after running it my display changed somewhat.

Note: We just setup trac for the first time and in the process of doing so "finished" a two week cycle, so some of the screwiness I am seeing may be due to the fact we have not done all the proper data entry. however, the missing button for completing a milestone concerns me...

Robert Kuropkat

comment:4 Changed 16 years ago by anonymous

I saw this too. Here's what's really up, the chart does not start updating until the day after you start the milestone (and then it doesn't actually change until one of its tickets is modified).

So the workaround is ignoring the messed up chart for a day.

comment:5 Changed 16 years ago by rangerden@…

Ok, another datapoint. I had the same symptoms: no "finish milestone" button present, char initially not drawn. I tried running manually, and the chart appeared. Note that my experience was not the same as reported by anonymous on 12/18/2007, in that I waited two days after starting the milestone and still saw no chart. When I ran, it stated that an insert was needed, which looks to me to indicate that it had never run before. I am using Trac 0.11b and sqlite.

comment:6 Changed 15 years ago by daan

Owner: changed from Sam Bloomquist to daan

comment:7 Changed 15 years ago by anonymous

same versions, same symptoms here, until I run the and additionnaly it said :

/var/lib/python-support/python2.4/trac/ UserWarning: Module burndown was already imported from /tmp/scrumburndownplugin/burndown/__init__.pyc, but /trac/plugins/TracBurndown-01.08.10-py2.4.egg is being added to sys.path
  egg.activate() has already been run today - update needed

having only 1 daily update is really disappointing..

comment:8 Changed 15 years ago by daan

Trac Release: 0.100.11 has already been run today - update needed

This means that the burndown job will update the values instead of inserting them (this is a notification, not an error). You can run the burndown job as often as you like (we run it once an hour).

I will look into these problems.

comment:9 Changed 15 years ago by anonymous

Maybe check your trac.ini for correct


Was wrong in my system.

comment:10 Changed 15 years ago by daan

Resolution: fixed
Status: newclosed

(In [5058]) Release of version 1.9.1 of the Trac Scrum burndown plugin. See for more information.

A new version of the Scrum Burndown plugin for Trac is released, bringing compatibility for PostgreSQL, MySQL, Trac, and many bug fixes. Upgrading is recommended.

New features The Scrum burndown plugin is currently compatible and tested with Trac 0.10.5, Trac 0.11.1, Trac Python 2.4 and Python 2.5. Additional to the previous SQLite compatibility, support for both PostgreSQL 8.3 and MySQL 5 has been added.

The following issues are fixed:

  • Fixes #1462 better control of milestone: a way to ‘reset’ a milestone
  • Fixes #1217 database upgrade fails after installing latest scrumburndownplugin
  • Fixes #2476 Error: ‘line_graph’ is undefined - stop graph from displaying
  • Fixes #1730 couldn’t upgrade
  • Fixes #2729 Error while running under PostgreSQL
  • Fixes #3102 fails INSERT NULL id
  • Fixes #1909 Overshooting estimate reduces remaining effort while ticket is open
  • Fixes #1189 TracBurndown-01.05.10-py2.4.egg error
  • Fixes #1800 No chart when clicking Burndown chart button.
  • Fixes #4047 AttributeError: ‘NoneType’ object has no attribute ‘getValue’
  • Fixes #2224 Changing ticket component causes removal from burndown
  • Fixes #2562 Creating a new component breaks the burndown graphic for “All Components”
  • Fixes #4222 Install fails on mysql
  • Fixes #2218 ScrumBurndownPlugin, trac 0.10.4, mysql

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain daan.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.