Modify

Opened 11 years ago

Closed 11 years ago

#203 closed defect (duplicate)

tracebacks loading trac pages with ldapplugin enabled

Reported by: jcruff@… Owned by: Emmanuel Blot
Priority: normal Component: LdapPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

received traceback loading '/browser' that stated:

File "build/bdist.linux-i686/egg/ldapplugin/model.py", 
line 77, in get_permission_groups
TypeError: unsupported operand type(s) for +: 'float' and 'str'

applying the following diff was a quick-fix:

--- ldapplugin/model.py 2006-03-05 17:18:47.000000000 -0500
+++ ldapplugin.new/model.py     2006-03-05 17:22:18.000000000 -0500
@@ -74,7 +74,7 @@
                 lut, groups = self._cache[username]
 
                 # ensures that the cache is not too old
-                if current_time < lut+self._cache_ttl:
+                if current_time < lut+float(self._cache_ttl):
                     # sources the cache
                     # cache lut is not updated to ensure
                     # it is refreshed on a regular basis

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by jcruff@…

Forgot the version of ldapplugin I was using:

 # svn info
Path: .
URL: http://trac-hacks.org/svn/ldapplugin/0.10
Repository UUID: 7322e99d-02ea-0310-aa39-e9a107903beb
Revision: 452
Node Kind: directory
Schedule: normal
Last Changed Author: eblot
Last Changed Rev: 396
Last Changed Date: 2006-01-22 18:23:19 -0500 (Sun, 22 Jan 2006)
Properties Last Updated: 2006-03-05 14:49:03 -0500 (Sun, 05 Mar 2006)

comment:2 Changed 11 years ago by anonymous

Resolution: duplicate
Status: newclosed

Sorry for the late delay. This is a duplicate of #200, I'll fix it, thanks for the report + patch

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Emmanuel Blot.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.