Opened 11 years ago

Closed 10 years ago

#2084 closed defect (fixed)

Report execution failed: near "AS": syntax error

Reported by: Varya Owned by: Russ Tyndall
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10


I intalled yoour Plugin (Timing and Estimation Plugin) and hope to USE menu point "Management" in main menu. I click at "Management" and have a page with some checkboxes and select fields and link for reports. When I click at the first link "Ticket Work Summury" I got a error 'Report execution failed: near "AS": syntax error'. What is my mistake? Thank you!

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Sergio Talens-Oliag

I've found the same problem and I've solved it upgrading the sqlite libraries.

The plugin was working OK on machines running Debian Etch, which includes the 3.3.8 version of the sqlite3 libraries, but when I tried it on an old installation that was runinng Debian Sarge I found the same problem as you.

My installation was using the python bindings for sqlite 2.8.16, and as I supposed it had something to do with such an old version I decided to see what was available on and found a backported version of the python bindings for sqlite3 (available from

I downloaded and installed the python2.3-pysqlite2 package with the sqlite3 libraries included with Sarge, but after restarting the error was still there.

As the sqlite3 version included with sarge was version 3.2.1 and I knew that the 3.3.8 version worked I went again to and found that there was a newer sqlite3 version available (the exact version is 3.3.5) and after installing it all works as exected.

I supose that all you need is to upgrade your system to use sqlite 3.3.x or use a different database backend, hope that this helps.

comment:2 Changed 10 years ago by anonymous

I hit this as well on a Debian etch system.

I have both sqlite (2.8.17-2) and sqlite3 (3.3.8-1.1) installed. However I had python-sqlite (1.0.1-5) installed, and not python-pysqlite2. I installed the latter (2.3.2-2) and restarted apache.

I got traceback errors, looked like I needed to upgrade the trac db. After a trac-admin ... upgrade I was rewarded with:

Command failed: file is encrypted or is not a database

So I backed out python-pysqlite2, and restarted apache. Luckily that was enough to recover the situation.

It appears I shall have to upgrade the database format to sqlite3 -

% sqlite3 db/trac.db
sqlite> .tables
Error: file is encrypted or is not a database

% sqlite db/trac.db
sqlite> .tables
attachment         custom_report      report             ticket           
auth_cookie        enum               revision           ticket_change    
azcalendar_event   milestone          session            ticket_custom    
bill_date          node_change        session_attribute  version          
component          permission         system             wiki             
sqlite> .dump version
CREATE TABLE version (
    name text PRIMARY KEY,
    time integer,
    description text
sqlite> .exit

May I suggest you document that this plugin requires sqlite3 and sqlite3-format databases? Which are incompatible with version 2 format databases? The link shows how to convert them.

comment:3 in reply to:  2 Changed 10 years ago by Russ Tyndall

Resolution: fixed
Status: newclosed

Replying to anonymous:

May I suggest you document that this plugin requires sqlite3 and sqlite3-format databases? Which are incompatible with version 2 format databases? The link shows how to convert them.

You mean like:

If you actually think there should be more documentation about this here, then please either feel free to either change it yourself (if you can or open a new ticket detailing what changes in documentation you think should happen and where this documentation should be presented.

I want this documentation to be good, but people have been getting this error consistently since the plugins release, and I have tried emphasizing the required versions section and moving it higher on the page, but it never seems to help.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Russ Tyndall.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.