Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#3153 closed enhancement (fixed)

[patch] Easy option to disable email verification

Reported by: Noah Kantrowitz Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: user email verifiy
Cc: Heikki Toivonen (remove -bugzilla when emailing directly) Trac Release: 0.11

Description

Attached patch adds a simple option to enable or disable email verification, as well as never trying to verify the address of an admin (so they can't get locked out of webadmin).

Entirely untested, but it is late and I am going to bed.

Attachments (1)

verify_email_option.patch (3.2 KB) - added by Noah Kantrowitz 9 years ago.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by Noah Kantrowitz

Attachment: verify_email_option.patch added

comment:1 Changed 9 years ago by Noah Kantrowitz

also I set the default to be to not verify addresses, as this is the current behavior of acct_mgr.

comment:2 Changed 9 years ago by Pedro Algarvio, aka, s0undt3ch

Owner: changed from Matt Good to Pedro Algarvio, aka, s0undt3ch
Status: newassigned

This can probably be marked a duplicate of #442 since what you address here is a fix for what's addressed on that ticket.

comment:3 Changed 9 years ago by Pedro Algarvio, aka, s0undt3ch

Owner: changed from Pedro Algarvio, aka, s0undt3ch to Matt Good
Status: assignednew

Dam! It's the 2nd time that when I comment a ticket, I wrongly become the owner of the ticket. Reverting it back.

comment:4 Changed 9 years ago by Heikki Toivonen (remove -bugzilla when emailing directly)

Cc: Heikki Toivonen (remove -bugzilla when emailing directly) added; anonymous removed

comment:5 Changed 9 years ago by Heikki Toivonen (remove -bugzilla when emailing directly)

comment:6 Changed 6 years ago by Steffen Hoffmann

Keywords: user email verifiy added
Owner: changed from Matt Good to Steffen Hoffmann
Summary: Easy option to disable email verification[patch] Easy option to disable email verification

Nice, certainly a reasonable request, as the admin web UI is already quit sophisticated, and it'll make a nice follow-up on [9277] as well, as you don't need to give access to plugin manager for activation/deactivation of the EmailVerificationModule.

comment:7 Changed 6 years ago by Steffen Hoffmann

Resolution: fixed
Status: newclosed

(In [9304]) AccountManagerPlugin: Add easy option to switch email verification from admin UI, closes #3153.

This is a follow-up to changeset [9277] as we introduce an easy way to enable/disable this feature while keeping the new default behavior of making email address verification mandatory on activation of EmailVerificationModule. I've taken the chance for some cosmetic changes as well, especially to remove radio buttons and use checkboxes consistently for all options.

comment:8 Changed 6 years ago by Steffen Hoffmann

(In [10519]) AccountManagerPlugin: Make option verify_email effective for RegistrationModule too, refs #3153, #3989, #5509 and #9051.

Only module state (enabled/disabled) has been checked before, when deciding on the email address field being optional vs. required since changeset [9304].

Modify Ticket

Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.