Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#3220 closed defect (fixed)

TypeError with AuthOpenId Plugin

Reported by: joe@… Owned by: dalius
Priority: normal Component: AuthOpenIdPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11


A new install of trac with a new install of authopenid gives the error "TypeError: not all arguments converted during string formatting" when entering an openid (it does not do this if a random string, or a url which is not an openid is entered)

With '', which is delegated to '' (same thing happens with my aol openid and yahoo), I get the following before being relayed:

Request parameters:

{'__FORM_TOKEN': u'76dd3ce9c86633ef985ec5f1',
 'openid_identifier': u''}

User Agent was: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9) Gecko/2008051202 Firefox/3.0

System Information

Trac 0.11rc2
Python 2.4.4 (#1, Oct 23 2006, 13:58:00)
[GCC 4.1.1 20061011 (Red Hat 4.1.1-30)]
setuptools 0.6c8
SQLite 3.3.6
pysqlite 1.1.7
Genshi 0.6dev-r888
mod_python 3.2.8
Subversion 1.4.3 (r23084)
jQuery: 1.2.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc2-py2.4.egg/trac/web/", line 423, in _dispatch_request
  File "/usr/lib/python2.4/site-packages/Trac-0.11rc2-py2.4.egg/trac/web/", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/authopenid/", line 180, in process_request
  File "build/bdist.linux-i686/egg/authopenid/", line 257, in _do_verify
  File "/usr/lib/python2.4/site-packages/openid/consumer/", line 354, in begin
    return self.beginWithoutDiscovery(service, anonymous)
  File "/usr/lib/python2.4/site-packages/openid/consumer/", line 377, in beginWithoutDiscovery
    auth_req = self.consumer.begin(service)
  File "/usr/lib/python2.4/site-packages/openid/consumer/", line 599, in begin
    assoc = self._getAssociation(service_endpoint)
  File "/usr/lib/python2.4/site-packages/openid/consumer/", line 1157, in _getAssociation
    assoc =
  File "/usr/lib/python2.4/site-packages/openid/store/", line 18, in wrapped
    return self._callInTransaction(func, self, *args, **kwargs)
  File "/usr/lib/python2.4/site-packages/openid/store/", line 172, in _callInTransaction
    ret = func(*args, **kwargs)
  File "/usr/lib/python2.4/site-packages/openid/store/", line 220, in txn_getAssociation
  File "/usr/lib/python2.4/site-packages/openid/store/", line 156, in func
    return self._execSQL(sql_name, *args)
  File "/usr/lib/python2.4/site-packages/openid/store/", line 147, in _execSQL
    self.cur.execute(sql, str_args)
  File "/usr/lib/python2.4/site-packages/sqlite/", line 255, in execute = self.con.db.execute(SQL % parms)
TypeError: not all arguments converted during string formatting

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by anonymous


[root@x2 authopenid-plugin]# python -V


[root@x2 python-openid-2.2.0]# python -V


comment:2 Changed 8 years ago by dalius

Have you tried using pysqlite2 ( That might be solution. As you can see from traceback problem is in python-openid library.

comment:3 Changed 8 years ago by joe@…

  • Resolution set to fixed
  • Status changed from new to closed

Thanks, I installed python-sqlite2 in yum and that fixed it

Sorry for the trouble

comment:4 Changed 8 years ago by dalius

No problem. New ticket is registered for OpenID library:

Add Comment

Modify Ticket

as closed The owner will remain dalius.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.