Opened 8 years ago

Last modified 12 months ago

#3340 new defect

Wysiwyg: Dislikes some nested definitions

Reported by: anonymous Owned by: jun66j5
Priority: normal Component: TracWysiwygPlugin
Severity: normal Keywords: WYSIWYG definition
Cc: Trac Release: 0.11


 * C

 * C

results in Failed to activate the wysiwyg editor.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by AdrianFritz

  • Keywords WYSIWYG added; Wysiwyg removed

comment:2 follow-up: Changed 5 years ago by anonymous

Same error occurs with a table where one cell contains an empty bold text (i.e. '''''').

comment:3 in reply to: ↑ 2 Changed 5 years ago by jun66j5

Replying to anonymous:

Same error occurs with a table where one cell contains an empty bold text (i.e. '''''').

It works for me. What version of tracwysiwyg do you use?

I tried the latest;

  1. Input || '''''' || to textarea
  2. Click wysiwyg radio button
  3. Wysiwyg editor is shown without errors

comment:4 Changed 13 months ago by jun66j5

#12450 was closed as duplicate.

comment:5 Changed 12 months ago by xoneca@…

So, I tried to debug this with the following snippet:

 First def:: 
  - first list
 Second def:: 
  - second list

I have tracked the bug to the function handleList() when parsing the second list (last line of that snippet). There the holder is the last dd element, so when calling

list = getSelfOrAncestor(holder, "li");

That returns null and blows at the next line, on appendBogusLineBreak().

comment:6 Changed 12 months ago by xoneca@…

Tried also the snippet in the ticket description and fails in the same function, but this time holder is a DocumentFragment element.

Add Comment

Modify Ticket

as new The owner will remain jun66j5.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.