Modify

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#3474 closed defect (fixed)

HDF dataset not available

Reported by: lucy.bridges@… Owned by: mikechml
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords:
Cc: nikunj.mehta@…, interstellar Trac Release: 0.11

Description

When clicking the 'Peer Review' tab I get the following error:

"Trac detected an internal error:

AssertionError: HDF dataset not available. Check your clearsilver installation"

I've installed the latest version of PeerReview and I've installed clearsilver 0.10.5 (as far as I can tell).

The system info is:

Trac: 0.11 Python: 2.4.3 (#1, Jun 13 2006, 16:41:18) [GCC 4.0.2 20051125 (Red Hat 4.0.2-8)] setuptools: 0.6c8 MySQL: server: "4.1.22-standard", client: "4.1.22", thread-safe: 1 MySQLdb: 1.2.2 Genshi: 0.5 mod_python: < 3.2 Pygments: 0.10 Subversion: 1.2.3 (r15833) jQuery: 1.2.3

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by anonymous

Cc: nikunj.mehta@… added; anonymous removed

comment:2 Changed 9 years ago by anonymous

Resolution: fixed
Status: newclosed

Problem resolved when ClearSilver was recompiled with python-bindings (./configure --with-python=/usr/bin/python) - not mentioned as required in the documentation, it was finally found in another bug report!

comment:3 Changed 9 years ago by trac-bugs.9.pbergen@…

Does this really work with genshi?

I thought trac.11 used Genshi and not clearsilver. How will installing clearsilver work? Does the scrumburndownplugin at all work with trac.11?

comment:4 Changed 9 years ago by anonymous

The python-bindings fix above works for me too. Many thanks.

comment:5 Changed 8 years ago by interstellar

Cc: interstellar added

I have a trac 0.11 on Ubuntu. I've installed http://trac-hacks.org/svn/peerreviewplugin/0.11/ and nothing didn't work. The error was:

AssertionError: HDF dataset not available. Check your clearsilver installation

then I tried: http://trac-hacks.org/svn/peerreviewplugin/tags/2.1-toddler-rc1 and all now works except the handle peerReviewSearch. Which gives the same error:

AssertionError: HDF dataset not available. Check your clearsilver installation

My System Information

Trac 0.11.4
Python 2.5.2 (r252:60911, Oct 5 2008, 19:42:18)
[GCC 4.3.2]
setuptools 0.6c9
SQLite 3.5.9
pysqlite 2.3.2
Genshi 0.5.1
mod_python 3.3.1
Pygments 1.0
Subversion 1.5.1 (r32289)
jQuery: 1.2.6

comment:6 Changed 7 years ago by anonymous

I have the same problem as interstellar.condition. I haven't tried fixing my python-bindings but I don't think that's the problem

Does the problem still exist for anyone?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain mikechml.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.