Modify

Opened 9 years ago

Closed 8 years ago

#3835 closed defect (duplicate)

Correct permission for ticket modify

Reported by: okamototk Owned by: Alec Thomas
Priority: normal Component: XmlRpcPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description (last modified by Odd Simon Simonsen)

Hi,

XmlRpcPlugin needs TRAC_ADMIN permission for update ticket. However I think it should be TRAC_MODIFY permission. I attached the pacth. Please improve it.

  • tracrpc/ticket.py

     
    2929        yield ('TICKET_VIEW', ((list, int),), self.getAvailableActions)
    3030        yield ('TICKET_VIEW', ((list, int),), self.get)
    3131        yield ('TICKET_CREATE', ((int, str, str), (int, str, str, dict), (int, str, str, dict, bool)), self.create)
    32         yield ('TICKET_ADMIN', ((list, int, str), (list, int, str, dict), (list, int, str, dict, bool)), self.update)
     32        yield ('TICKET_MODIFY', ((list, int, str), (list, int,str, dict), (list, int, str, dict, bool)), self.update)
    3333        yield ('TICKET_ADMIN', ((None, int),), self.delete)
    3434        yield ('TICKET_VIEW', ((dict, int), (dict, int, int)), self.changeLog)
    3535        yield ('TICKET_VIEW', ((list, int),), self.listAttachments)

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by seltmann@…

would be nice for me too

comment:2 Changed 8 years ago by Odd Simon Simonsen

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Closing as duplicate of #3642.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Alec Thomas.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.