Modify

Opened 14 years ago

Closed 12 years ago

Last modified 11 years ago

#4223 closed defect (fixed)

Bad CSS interpretation with IE

Reported by: anonymous Owned by: Alec Thomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords: CSS
Cc: Trac Release: 0.11

Description

IE sticks every tag to each other, there's no space between them. I know IE is a pain but i use it like a lot of people ;)

ul.tagcloud { list-style: none; }
.tagcloud li { display: inline; }
.tagcloud li:after { content: ", "; }
.tagcloud li.last:after { content: ""; }

Attachments (1)

tractags-ie.jpg (37.8 KB) - added by Sébastien GISSINGER 14 years ago.

Download all attachments as: .zip

Change History (8)

Changed 14 years ago by Sébastien GISSINGER

Attachment: tractags-ie.jpg added

comment:1 Changed 14 years ago by Sébastien GISSINGER

You could add only one space between tags in your code, no matter if IE users do not see the comma but it would be cool to have a better rendering than this provided in the attachment.

Cheers

comment:2 Changed 13 years ago by nulleke

You can solve the display in ie by adding as space like sgissinger already noticed.

I created a little patch that does exactly that

--- macros.py.orig      2009-02-18 10:11:22.000000000 +0100
+++ macros.py   2009-02-18 08:46:20.000000000 +0100
@@ -50,7 +50,7 @@
         if i == last:
             li(class_='last')
         li()
-        ul(li)
+        ul(li, ' ')
     return ul

comment:3 Changed 13 years ago by J Evan S

#4465 closed as duplicate

comment:4 Changed 12 years ago by Michael Renzmann

Resolution: fixed
Status: newclosed

(In [7376]) IE ignores css stuff which ensures that tags in the tag cloud are not sticking to each other. Add a space after each </li> HTML tag as workaround, as suggested in #4223. Worked as intended in a quick test. Fixes #4223.

comment:5 in reply to:  4 Changed 12 years ago by Michael Renzmann

Replying to otaku42:

(In [7376]) IE ignores css stuff which ensures that tags in the tag cloud are not sticking to each other. Add a space after each </li> HTML tag as workaround, as suggested in #4223. Worked as intended in a quick test. Fixes #4223.

Guess I had a bad day:

I accidentally committed stuff to the tagged release v0.6 rather than to trunk, which of course was wrong. I'll thus roll back r7376 and re-apply the patch to trunk.

comment:6 Changed 12 years ago by Michael Renzmann

(In [7380]) IE ignores css stuff which ensures that tags in the tag cloud are not sticking to each other. Add a space after each </li> HTML tag as workaround, as suggested in #4223. Worked as intended in a quick test. Fixes #4223.

comment:7 Changed 11 years ago by Steffen Hoffmann

Keywords: CSS added
Summary: bad css interpretation with IEBad CSS interpretation with IE

As a matter of fact this is one of the most notable improvements over tractags-0.6, at least for the occasional and average user. Just making sure, this has more suitable title for the upcoming changelog for tractags-0.7 .

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Alec Thomas.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.