Modify

Opened 11 years ago

Closed 11 years ago

#463 closed defect (fixed)

graphviz plugin problem

Reported by: izghitu@… Owned by: Peter Kropf
Priority: normal Component: GraphvizPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description (last modified by Noah Kantrowitz)

Hello, I have 2 Fedora Core 4 servers with python-2.4.1-2

I installed the graphviz plugin for trac (I have trac 0.9.5) On the first server everything went smooth without any problems. However on the second server after doing everything just like on the first one I get this error when trying to use graphviz:

Trac detected an internal
error: [Errno 32] Broken pipe

Python traceback Traceback (most recent call last):

File "/usr/lib/python2.4/site-packages/trac/web/cgi_frontend.py", line
130, in run

dispatch_request(req.path_info, req, env)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in
dispatch_request

dispatcher.dispatch(req)

File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch

resp = chosen_handler.process_request(req)

File "/usr/lib/python2.4/site-packages/trac/wiki/web_ui.py", line 92,
in process_request

self._render_editor(req, db, page, preview=True)

File "/usr/lib/python2.4/site-packages/trac/wiki/web_ui.py", line 311,
in _render_editor

infopage_html? = wiki_to_html(page.text, self.env, req, db)

File "/usr/lib/python2.4/site-packages/trac/wiki/formatter.py", line
747, in wiki_to_html

Formatter(env, req, absurls, db).format(wikitext, out, escape_newlines)

File "/usr/lib/python2.4/site-packages/trac/wiki/formatter.py", line
576, in format

self.handle_code_block(line)

File "/usr/lib/python2.4/site-packages/trac/wiki/formatter.py", line
546, in handle_code_block

self.out.write(self.code_processor.process(self.req, self.code_text))

File "/usr/lib/python2.4/site-packages/trac/wiki/formatter.py", line
108, in process

text = self.processor(req, text)

File "/usr/lib/python2.4/site-packages/trac/wiki/formatter.py", line
98, in _macro_processor

return macro_provider.render_macro(req, self.name, text)

File "/home/trac/scs/plugins/graphviz-0.6.3-py2.4.egg/graphviz/graphviz.py",
line 169, in render_macro File
"/home/trac/scs/plugins/graphviz-0.6.3-py2.4.egg/graphviz/graphviz.py",
line 369, in launch

IOError: [Errno 32] Broken pipe

Please help Thank you

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by Peter Kropf

It seems that the Fedora graphviz package wasn't installed. This should have been detected by the configuration checking code but wasn't. Perhaps there's some Fedora specific problem with checking for the existance of the dot, neato and other graphviz programs. I bit more debugging into the problem is needed...

comment:2 Changed 11 years ago by Noah Kantrowitz

Description: modified (diff)

Fixing traceback.

comment:3 Changed 11 years ago by Peter Kropf

Resolution: fixed
Status: newclosed

Since this seems to be resolved with installing graphviz, I'm going to close this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Peter Kropf.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.