Modify

Opened 11 years ago

Closed 11 years ago

#534 closed defect (fixed)

Login/Logout page isnt working properly

Reported by: ch3nyong Owned by: Matt Good
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: needinfo
Cc: Trac Release: 0.9

Description

When login link was activated, user is able to log in with their username and password. However, the login page did not response. When user refreshed the trac page, it indicated that the user has been logged in.

The same problem goes to the logout link. When user clicked on logout link, it showed nothing where it actually logged out the user. User again, needs to refresh the page in order to see the changes.

I found this statement in the log file, but am not sure what it means: " Trac[api] DEBUG: Updating wiki page index "

It happened to IE/Opera/Mozilla browsers (others not tested).

I tried removing/re-enabling plugins, restart server but all doesnt seem to work.

I'm running Trac 0.10dev on tracd. Thank you!

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by Matt Good

Keywords: needinfo added
Priority: highnormal
Severity: blockernormal

Please provide a listing of the HTTP headers as captured by LiveHTTPHeaders or a similar tool. I need some more info here to debug this.

comment:2 Changed 11 years ago by ch3nyong

Resolution: fixed
Status: newclosed

I spent hours on it to found out that it was caused by a minor mistake. It happened to be missing of some arguements in trac.ini

base_url = 
htdocs_location = 

Have them set up, it runs perfectly!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Matt Good.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.