Modify

Opened 7 years ago

Closed 6 years ago

Last modified 3 years ago

#6184 closed defect (duplicate)

ProgrammingError: Cannot operate on a closed cursor.

Reported by: anonymous Owned by: Sebastian Marek
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords: ProgrammingError, closed, cursor
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /peerReviewView, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'Review': u'1', 'Vote': u'yes', '__FORM_TOKEN': u'b2907177f4084a0a049cefb7'}

User Agent was: Mozilla/5.0 (Windows; U; Windows NT 6.0; zh-CN; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

System Information

Trac 0.11.5
Python 2.6.4 (r264:75706, Oct 29 2009, 15:55:15)
[GCC 4.4.1]
setuptools 0.6c11
SQLite 3.6.16
pysqlite 2.5.5
Genshi 0.5.1
mod_python 3.3.1
Pygments 1.0
Subversion 1.6.5 (r38866)
jQuery: 1.3.2

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 205, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/codereview/peerReviewView.py", line 167, in process_request
    self.vote("1", reviewID, req)
  File "build/bdist.linux-i686/egg/codereview/peerReviewView.py", line 208, in vote
    reviewEntry.save(db)
  File "build/bdist.linux-i686/egg/codereview/ReviewerStruct.py", line 46, in save
    cursor.execute(query)
  File "/usr/lib/python2.6/dist-packages/trac/db/util.py", line 60, in execute
    return self.cursor.execute(sql)
  File "/usr/lib/python2.6/dist-packages/trac/db/sqlite_backend.py", line 58, in execute
    args or [])
  File "/usr/lib/python2.6/dist-packages/trac/db/sqlite_backend.py", line 50, in _rollback_on_error
    return function(self, *args, **kwargs)
ProgrammingError: Cannot operate on a closed cursor.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #5552.

comment:2 Changed 3 years ago by Ryan J Ollos

Keywords: ProgrammingError closed cursor added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Sebastian Marek.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.