Modify

Opened 8 years ago

Closed 7 years ago

Last modified 5 years ago

#6766 closed defect (fixed)

[PATCH] MasterTicketsPlugin produces traceback on trying to view diff that only affects descr

Reported by: David Fraser Owned by: Noah Kantrowitz
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I got the following traceback when trying to click on the diff for a change to descr:

2010-03-04 06:22:20,646 Trac[main] ERROR: Exception caught while post-processing request:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 238, in dispatch
    self._post_process_request(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 310, in _post_process_request
    f.post_process_request(req, *(None,)*extra_arg_count)
  File "build/bdist.linux-x86_64/egg/mastertickets/web_ui.py", line 44, in post_process_request
    tkt = data['ticket']
TypeError: 'NoneType' object is unsubscriptable
2010-03-04 06:22:20,646 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 444, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 216, in dispatch
    self._post_process_request(req, *resp)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 308, in _post_process_request
    resp = f.post_process_request(req, *resp)
  File "build/bdist.linux-x86_64/egg/mastertickets/web_ui.py", line 64, in post_process_request
    for field, field_data in change['fields'].iteritems():
KeyError: 'fields'

Attachments (1)

masterticketsplugin-fix6766.patch (683 bytes) - added by David Fraser 8 years ago.
Patch that fixes the second traceback here

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by David Fraser

Patch that fixes the second traceback here

comment:1 Changed 8 years ago by David Fraser

Summary: MasterTicketsPlugin produces traceback on trying to view diff that only affects descr[PATCH] MasterTicketsPlugin produces traceback on trying to view diff that only affects descr

comment:2 Changed 7 years ago by Grzegorz Sobański

Resolution: duplicate
Status: newclosed

Duplicate of #3920

comment:3 Changed 5 years ago by Ryan J Ollos

Resolution: duplicatefixed

(In [12910]) Fix #5503, #6766 and #3920 with the patch from #3920: http://trac-hacks.org/attachment/ticket/3920/fix_ticket_diff.patch

[Patch] Error in code causing diff crash on tickets with changes in description only (web_ui.py)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Noah Kantrowitz.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.