Modify

Opened 7 years ago

Closed 20 months ago

#6787 closed defect (wontfix)

Voting control not present on installation with Agilo plugin

Reported by: mbuisman@… Owned by: Ryan J Ollos
Priority: low Component: VotePlugin
Severity: normal Keywords: needinfo
Cc: Trac Release: 0.11

Description (last modified by Ryan J Ollos)

The plugin shows up in the admin page (enabled), I gave myself VOTE_MODIFY and VOTE_VIEW permissions, tried it as a TRAC_ADMIN, tried paths = wiki/*, ticket/* and wiki/.*, ticket/.* and ticket*, wiki* and just * (which results in "nothing to repeat error"), and tinkered with base_url, but I can't see the voting controls in either a ticket or a wiki page, neither in the rendered page, nor in the html. I expected to see some controls top right. Nothing in the log at DEBUG level

What can I do to get voting to work?

Note: I'm running 0.11.7 stable and using the Agilo plugin, which changes the look quite a bit.

Attachments (1)

plugins.pdf (253.4 KB) - added by mbuisman@… 6 years ago.
printout of config page for non working installation

Download all attachments as: .zip

Change History (16)

comment:1 Changed 7 years ago by Ryan J Ollos

Owner: changed from Alec Thomas to Ryan J Ollos

Reassigning ticket to new maintainer.

comment:2 Changed 7 years ago by Ryan J Ollos

Summary: all seems fine, except I can't see the voting controlsVoting control not present on installation with Agilo plugin

Please temporarily disable Agilo and let us know if you see the VotePlugin controls. If not, please disable all plugins and report back about that as well.

comment:3 Changed 7 years ago by Ryan J Ollos

Keywords: needs-info added

comment:4 Changed 7 years ago by Ryan J Ollos

Severity: blockernormal

comment:5 Changed 7 years ago by Ryan J Ollos

I'll leave this open for a month and then close if no more info is provided.

Changed 6 years ago by mbuisman@…

Attachment: plugins.pdf added

printout of config page for non working installation

comment:6 Changed 6 years ago by mbuisman@…

I have tried turning Agilo off, enabling the trac voting plugin and I still don't see the voting controls in wiki pages. I have attached a printout of my config (in which I had disabled trac voting again).

comment:7 Changed 6 years ago by Ryan J Ollos

Status: newassigned

My next guess is a conflict with the FiveStarVotePlugin (which was derived from the VotePlugin). Could you try temporarily disabling that plugin and see what the result is?

comment:8 Changed 6 years ago by mbuisman@…

Thanks for taking the time to guess. I tried the VotePlugin before ever installing the FiveStarVotePlugin; the VotePlugin was my first choice. When it didn't work, I tried FiveStarVotePlugin and that worked. So if you say VP is based on FSVP, and the latter works, could that be helpful in pinpointing the cause of the problem?

comment:9 in reply to:  8 Changed 6 years ago by Ryan J Ollos

Replying to mbuisman@emidconsult.com:

So if you say VP is based on FSVP, and the latter works, could that be helpful in pinpointing the cause of the problem?

Good point. I have permission to take over maintenance of the FiveStarVotePlugin (#7589), and will look at whether the functionality can be merged into VotePlugin. At the same time, I'll compare the code-bases and see if anything jumps out.

I should have some more info for you by, or sometime over, the weekend.

comment:10 Changed 6 years ago by Steffen Hoffmann

Keywords: needinfo added; needs-info removed

Just to unify the "info-needed" tags accoss whole t-h.o site.

comment:11 Changed 4 years ago by Ryan J Ollos

Sorry for the long delayed reply here. We need to figure out why the VotePlugin is not loading correctly. Please turn on t:TracLogging, and look for messages about the plugin loading while restarting Trac.

comment:12 Changed 4 years ago by Ryan J Ollos

Description: modified (diff)

comment:13 Changed 4 years ago by Steffen Hoffmann

Priority: normallow

This is likely related to #10706, so I suggest, that it is fixed at least since r13079 and following re-factoring of SQL statements.

Judging from missing feedback it seems not so important for the OP anymore. At least until we know, that there's still something to be done here, the priority is not high. Still you, Ryan, may want to keep it open until after next release due to the rather long time without developer feedback.

comment:14 Changed 4 years ago by Ryan J Ollos

Status: assignednew

comment:15 Changed 20 months ago by Ryan J Ollos

Resolution: wontfix
Status: newclosed

Please test the latest with Agilo and report back if it's not working.

Modify Ticket

Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.