Opened 18 years ago
Closed 16 years ago
#710 closed task (wontfix)
Python module name should be more explicit
Reported by: | Owned by: | Matt Good | |
---|---|---|---|
Priority: | normal | Component: | AccountManagerPlugin |
Severity: | minor | Keywords: | |
Cc: | Trac Release: | 0.9 |
Description
Right now, the plugin's module name is "acct_mgr". It would make more sense for it to be named something like "tracaccountmanager", especially when installed into site-packages. It wouldn't be ambiguous and there probably wouldn't be any chance for it to conflict with other potential packages.
That, and PEP 8 says module names shouldn't contain underscores.
Attachments (1)
Change History (5)
comment:1 Changed 18 years ago by
Type: | defect → task |
---|
comment:2 Changed 17 years ago by
Owner: | changed from Matt Good to jluna |
---|---|
Status: | new → assigned |
I don't find it intuitive either.
I created a simple patch to rename the acct_mgr
module to accountmanager
. acct_mgr
is left mapped to the accountmanager
directory (see the Distutils package-dir specification).
Alternatively, without having to rely on Distutils magic, and retaining the ability to log a depreciation notice when acct_mgr
is used...
class acct_mgr(Component): def __getattr__(self, attr): self.log.warning('Plugin \'acct_mgr\' was renamed to \'accountmanager\' and is subject to later removal.') return getattr(acountmanager, attr)
...added as an entry-point to plugins.trac
.
comment:3 Changed 17 years ago by
Owner: | changed from jluna to Matt Good |
---|---|
Status: | assigned → new |
Changed 17 years ago by
Attachment: | package_rename_to_accountmanager-trunk-r2547.patch added |
---|
comment:4 Changed 16 years ago by
Resolution: | → wontfix |
---|---|
Status: | new → closed |
I'm closing this as won't fix because most of account manager will be merged into core. Hopefully for 0.12, but most likely for 0.13. Doesn't make sense to jump through hoops for what will eventually become a non-issue.
Installing into site-packages will still put it in "TracAccountManager-version.egg", so it should be pretty clear. I'm not in a terrible rush to do this, since I've seen no real problems from the name, and changing it would break the config for current users.