Modify

Opened 7 years ago

Closed 4 years ago

#7527 closed defect (fixed)

Genshi error happens when I do a Display/Refresh in LogViewer page

Reported by: Anton Voßel Owned by: izzy
Priority: normal Component: LogViewerPlugin
Severity: normal Keywords: unicode utf8
Cc: Trac Release: 0.12

Description

Genshi UnicodeDecodeError error while rendering template 'logviewer.html', line 53, char 3

Trac 0.11.7.1dev-r0 LoViewerPlugin 0.2

Attachments (3)

logviewer-error1.jpg (105.8 KB) - added by anton.vossel@… 7 years ago.
logviewer-error2.jpg (86.6 KB) - added by Anton Voßel 7 years ago.
ticket7527-logviewerplugin-trunk-r13332.diff (777 bytes) - added by Jun Omae 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 7 years ago by anton.vossel@…

Attachment: logviewer-error1.jpg added

Changed 7 years ago by Anton Voßel

Attachment: logviewer-error2.jpg added

comment:1 Changed 7 years ago by izzy

Thank you for your report. But to figure out what the problem is, I need some more details:

  • Could you please enable logging for your trac instance and then post the full error stack?
  • Could you tell me what character set you are using? (stupid question probably, as it will be utf-8), and what your operating system itself is using (btw, which OS?)?
  • If you have any idea what text you expected, so we might guess the character which broke it, this would be helpful as well.

Thanx in advance, Izzy.

comment:2 in reply to:  1 ; Changed 4 years ago by Tomas Pelka

Trac Release: 0.110.12

Replying to izzy:

Thank you for your report. But to figure out what the problem is, I need some more details:

  • Could you please enable logging for your trac instance and then post the full error stack?
  • Could you tell me what character set you are using? (stupid question probably, as it will be utf-8), and what your operating system itself is using (btw, which OS?)?
  • If you have any idea what text you expected, so we might guess the character which broke it, this would be helpful as well.

Thanx in advance, Izzy.

Facing this issue as well, Linux (64b), utf-8, Trac 0.12.4, LogViewerPlugin 0.2.

I'm sorry I cant get any more verbose backtrace.

Changed 4 years ago by Jun Omae

comment:3 in reply to:  2 ; Changed 4 years ago by Jun Omae

Replying to tompelka@…:

Facing this issue as well, Linux (64b), utf-8, Trac 0.12.4, LogViewerPlugin 0.2.

Try ticket7527-logviewerplugin-trunk-r13332.diff, Genshi template requires unicode instances.

comment:4 in reply to:  3 Changed 4 years ago by Tomas Pelka

Replying to jun66j5:

Replying to tompelka@…:

Facing this issue as well, Linux (64b), utf-8, Trac 0.12.4, LogViewerPlugin 0.2.

Try ticket7527-logviewerplugin-trunk-r13332.diff, Genshi template requires unicode instances.

This is working as a charm, thanks a lot.

Tom

comment:5 Changed 4 years ago by izzy

Keywords: unicode utf8 added
Resolution: fixed
Status: newclosed

Sorry for the long delay, I'm currently quite busy on a lot of projects. Lucky for you all, one of them is upgrading a Trac installation to v1.0 which includes this plugin :)

Thanks for the patch! In fact, that fixed the main part of the issue. An additional minor change was required at the top of the file, declaring it utf8-encoded (# -*- coding: utf-8 -*-). Included this fix with r13412.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain izzy.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.