Modify

Opened 7 years ago

Closed 2 years ago

#7665 closed defect (wontfix)

post-receive hook is not working when default repository is speciefied

Reported by: ivan@… Owned by: Herbert Valerio Riedel
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I'm using trac 0.12 with TracGit 0.12.0.2dev-r7757

I have several repositories. Here is the fragment of my trac.ini:

[repositories]
sample.dir = /var/git/sample.git/
sample.description = sample
sample.type = git 
test.dir = /var/git/test.git
test.description = test
test.type = git 

I also use post-receive hook as written on http://trac-hacks.org/wiki/GitPlugin#post-receivehookscripts to write comments in trac tickets if in git commit there is text like "See #123.". The problem is that if I specify the default repsitory, the post-receive hook script works only for the default repository. And for other repos I got such error in trac.log:

2010-09-10 14:57:23,186 Trac[PyGIT] INFO: read_commit failed for 'None' ('e2ec42273325a51cb832d01544e9123f1d7a466a')

I'm enaibling default repo by adding this lines to the [repositories] block

.alias = sample
.hidden = false

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by anonymous

Have you modified the

REPO_NAME = '(default)'

line accordingly?

comment:2 Changed 2 years ago by Ryan J Ollos

Resolution: wontfix
Status: newclosed

GitPlugin is deprecated. Please upgrade to Trac 1.0 and use TracGit.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Herbert Valerio Riedel.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.