default of estimation_field should be 'remaininghours' instead of 'estimatedhours'
|Reported by:||falkb||Owned by:||osimons|
|Cc:||osimons, rjollos||Trac Release:||0.12|
This change will ensure compatibility to TimingAndEstimationPlugin as well as to TracJsGanttPlugin. Those Trac plugins use 'estimatedhours' in the meaning of 'originally planned', and 'remaininghours' in the meaning of 'currently still expected hours'.
EstimationToolsPlugin always works in the meaning of tracking the 'currently still expected hours' but uses 'estimatedhours' for it. This clashes with the other plugins.
It should also use 'remaininghours' as internal default if
[estimation-tools] estimation_field = 'remaininghours'
is not set in trac.ini.
I fell into this trap and
- had to set
estimation_field = 'remaininghours'
- and also had to directly tweak the database this way:
UPDATE ticket_change SET field='remaininghours' WHERE field = 'estimatedhours' UPDATE ticket_custom SET name='remaininghours' WHERE name = 'estimatedhours'
The whole thing is reasoned in a missing mandatory overall-Trac naming convention concerning to such ticket fields. This probably should go into an extra new ticket...