Modify

Opened 6 years ago

Closed 4 years ago

#8716 closed defect (duplicate)

TracWysiwyg-0.12.0.3_r9676 , breaks in combination with some other plugins

Reported by: mwg@… Owned by: Jun Omae
Priority: normal Component: TracWysiwygPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Test case :

Linux 2.6.18-194.32.1.el5 x86_64 (CentOS5, python2.4 installed but not used to run Trac)
Python-2.7.1 (built with --enable-shared)
Trac-0.12.2-py2.7 (installed by easy_install-2.7, brought up by mod_wsgi)

add TracWysiwyg-0.12.0.3_r9676-py2.7 (installed by easy_install-2.7)
enable TracWysiwyg in Admin/Plugins panel
reload a ticket page and see Wysiwyg works in its editor fields

add TracTicketDelete-2.0.1-py2.7 (by easy_install-2.7)
enable TracTicketDelete in Admin/Plugins
reload a ticket page and see Wysiwyg does not work at all

disable TracTicketDelete, reload ticket, see Wysiwyg works again

Also I noticed that enabling TracTicketDelete breaks date chooser of 'TracDateField-1.0.1-py2.7' plugin

another case :

add timingandestimationplugin-1.1.2b-py2.7
enable its 4 submodules listed in TimingAndEstimationPlugin
reload ticket, see Wysiwyg works
enable the rest of timingandestimationplugin submodules,
reload ticket, see Wysiwyg breaks (Wysiwyg radio button is there, but on selecting it, edited text disappears, and reappears only on selecting Textarea radio-button again)
I narrowed this down to T&E submodules 'HoursLayoutChanger' and 'TicketPropsLayoutChanger' : enabling these breaks Wysiwyg.

Please try to reproduce it on your side.
Probably this ticket should be relayed to TicketDeletePlugin and TimingAndEstimationPlugin components, but I am reporting it here because for us Wysiwyg is more important and visible in our Trac.

Thank you in advance for your help.

Attachments (0)

Change History (2)

comment:1 in reply to:  description Changed 6 years ago by Jun Omae

Replying to mwg@mwg.dp.ua: Thanks for your reporting. I think that the issue is not wysiwyg bug.

add TracTicketDelete-2.0.1-py2.7 (by easy_install-2.7)
enable TracTicketDelete in Admin/Plugins
reload a ticket page and see Wysiwyg does not work at all

This is ticketdeleteplugin issue. I have posted the patch on ticket:6442. See comment:ticket:6442:2.

another case :

add timingandestimationplugin-1.1.2b-py2.7
enable its 4 submodules listed in TimingAndEstimationPlugin
reload ticket, see Wysiwyg works
enable the rest of timingandestimationplugin submodules,
reload ticket, see Wysiwyg breaks (Wysiwyg radio button is there, but on selecting it, edited text disappears, and reappears only on selecting Textarea radio-button again)
I narrowed this down to T&E submodules 'HoursLayoutChanger' and 'TicketPropsLayoutChanger' : enabling these breaks Wysiwyg.

This issue has reported on ticket:8314. If it can be reproduced, Please reopen the ticket.

comment:2 Changed 4 years ago by Jun Omae

Resolution: duplicate
Status: newclosed

A duplicate of #8314.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Jun Omae.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.