Modify

Opened 6 years ago

Closed 3 years ago

#9071 closed defect (fixed)

can't work with 0.12

Reported by: jeanvixue@… Owned by: Ryan J Ollos
Priority: normal Component: AwesomeAttachmentsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

Can it work with Trac 0.12? At create ticket form, no field for attachments.

I checked I has attachments button, when press create ticket, show error message:

KeyError: attachment[]

how?

Attachments (0)

Change History (9)

comment:1 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)

comment:2 Changed 5 years ago by Ryan J Ollos

(In [12185]) Refs #9071: Attempted to get AwesomeAttachmentsPlugin working, but it still needs more work.

  • Entry point in setup.py was not correct.
  • Renamed awesomattachments.py to awesomeattachments.py.
  • Fixed indentation problems in source code.
  • Get the attachments: max_size option from Config rather than re-defining the option.

It appears that this plugin may rely on a patched instance of Trac. The attachment fieldset and children are now added to the newticket form, but attachments are not added to the ticket when it is created.

comment:3 Changed 5 years ago by Ryan J Ollos

(In [12187]) Refs #9071: Declared the license as 3-Clause BSD, following a discussion with the original author Dan Ordille over email exchange.

comment:4 in reply to:  2 Changed 5 years ago by Ryan J Ollos

Replying to rjollos:

[...] It appears that this plugin may rely on a patched instance of Trac.

Rather, it inherits from TicketModule and over-rides the private method _do_save, which will make maintenance difficult, but I'm not sure yet that there is another way to accomplish this.

comment:5 Changed 5 years ago by Ryan J Ollos

(In [12188]) Refs #9071: Set version to 0.3dev. Added author to setup.py.

comment:6 Changed 5 years ago by Ryan J Ollos

(In [12186]) Refs #9071: Fixed some errors in [12185], which were masked because awesomeattachments.pyc was still being imported in the development environment.

comment:7 Changed 3 years ago by Ryan J Ollos

Owner: changed from Dan Ordille to Ryan J Ollos
Status: newassigned

comment:8 Changed 3 years ago by Ryan J Ollos

In 13603:

0.3dev: Fixed regression and various non-functional changes. Refs #9071.

  • Import of TracError class was missing since [12185].
  • PEP-0008 and other style changes.
  • Removed unused (and malformed) CSS.

comment:9 Changed 3 years ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.