Modify

Opened 6 years ago

Closed 5 years ago

#9588 closed defect (fixed)

upgrade process raises error when using multiple schemas in postgresql

Reported by: Kamyar Owned by: Russ Tyndall
Priority: high Component: TimingAndEstimationPlugin
Severity: blocker Keywords: waiting-for-feedback
Cc: Trac Release: 0.11

Description

We are using multiple trac environments each of which are placed in a postgresql database schema (Single database). The first time the upgrade took place successfully for one of the database schema. For the rest of environments it raises the error:

InternalError: current transaction is aborted, commands ignored until end of tra nsaction block

Even using --no-backup does not help.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by Russ Tyndall

I will try to get you straightened out, but first I am going to need a bit more info.

I need versions for postgres, trac, the python postgres bridge you are using, and the version of this plugin that you are using. Also helpful would be to enable TracLogging and post a log of the upgrade failing.

We run mulitple tracs from a single PG database (each trac in its own schema) and this has always worked for us (just so you know that this is indeed a supported way to run these packages). That said, MANY errors in trac manifest as a failure to upgrade.

Once you have posted this information, hopefully we can get you running pretty quickly.

Russ

comment:2 Changed 6 years ago by Russ Tyndall

Keywords: waiting-for-feedback added

comment:3 Changed 5 years ago by Russ Tyndall

Resolution: fixed
Status: newclosed

Just FYI, I just experienced the bug that you wrote about. I version 1.2.3 definitely works for me (I had it fail on 1.2.2 then work after upgrading to 1.2.3). The only problem I had after updating was that the system had previously set the version in the system table for key custom_report_manager_version to 1 (even though it had failed the upgrade process). I solved this annoyance in 1.2.4 (so an upgrade should succeed now).

Hopefully you should have no more trouble with this. Sorry it took so long to address this, I had not experienced the error till #9629 got me to track this down and fix it. Feel free to reopen if this is not meeting your needs

Cheers and thanks for the bug report, Russ

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Russ Tyndall.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.