Modify

Opened 5 years ago

Closed 3 months ago

Last modified 3 months ago

#9609 closed enhancement (duplicate)

Support relative download directory path in conf

Reported by: Jonas Bardino Owned by: Ryan J Ollos
Priority: normal Component: DownloadsPlugin
Severity: minor Keywords: relative path conf
Cc: Ryan J Ollos Trac Release: 0.11

Description

I would like to have relative downloads path support so that I can use a single inherited trac.ini for all my Trac instances:

[downloads]
path = downloads

If I try that with the latest 0.11 release I get a path error when uploading:

2011-12-13 10:05:33,616 Trac[main] WARNING: HTTPInternalError: 500 Trac Error (Error storing file somefile.zip! Is dir
ectory specified in path config option in [downloads] section of trac.ini existing?)

I've attached a simple patch that mirrors the graphviz plugin cache_dir extraction to achieve the goal.

Feel free to apply it as is or implement it in a better way.

---

Downloadsplugin: 0.11 branch (r11035, pip installed from trac-hacks.org)
Trac: 0.11.7-4 debian package
Server: Apache 2.2.16-6+squeeze4 debian package
Database: sqlite 3.7.3-1 debian package
OS: Linux

Attachments (1)

api.py.diff (1.2 KB) - added by Jonas Bardino 5 years ago.
patch against api.py to support relative path (updated source path so 'patch -p0 < api.py.diff' works)

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Jonas Bardino

Attachment: api.py.diff added

patch against api.py to support relative path (updated source path so 'patch -p0 < api.py.diff' works)

comment:1 Changed 5 years ago by Ryan J Ollos

Cc: Ryan J Ollos added; anonymous removed

comment:2 Changed 3 years ago by Ryan J Ollos

Owner: changed from Radek Bartoň to Ryan J Ollos
Status: newassigned

comment:3 Changed 3 months ago by Ryan J Ollos

Resolution: duplicate
Status: assignedclosed

This was fixed in r7897. Duplicate of #7031.

comment:4 Changed 3 months ago by Ryan J Ollos

In 16022:

1.0.0dev: Remove duplicate path option

Refs #7031, #9609.

Modify Ticket

Action
as closed The owner will remain Ryan J Ollos.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.