Modify

Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#9709 closed defect (cantfix)

installation fails with "IndexError: list index out of range"

Reported by: Bram Owned by: Chris Nelson
Priority: normal Component: TracJsGanttPlugin
Severity: normal Keywords: installation fails setuptools svn-1.7
Cc: Trac Release: 0.12

Description (last modified by Ryan J Ollos)

Hello,

I'm currently trying to install the plugin to a windows Server 2008 machine with Python 2.6.5 and Trac 0.12.2. When I start the easy_install, after a while it ends with:

IndexError: list index out of range"

The latest working line was:

python\lib\site-packages\setuptools-0.6c11-py2.6.egg\setuptools\command\egg_info.py", line 233, in get_svn_revision

Attachments (0)

Change History (11)

comment:1 Changed 5 years ago by Chris Nelson

I'm sorry but I don't have Windows, Trac 0.12, or Subversion.

comment:2 Changed 5 years ago by external+edgewall.org@…

I'm getting the same error trying to install Bitten. Not sure if it's related.

C:\Documents and Settings\Administrator\bitten-trunk>python setup.py --without-m
aster install
running install
running bdist_egg
Traceback (most recent call last):
  File "setup.py", line 158, in <module>
    cmdclass = {'build_doc': build_doc, 'test_doc': test_doc}
  File "C:\Python27\lib\distutils\core.py", line 152, in setup
    dist.run_commands()
  File "C:\Python27\lib\distutils\dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "C:\Python27\lib\distutils\dist.py", line 972, in run_command
    cmd_obj.run()
  File "C:\Python27\lib\site-packages\setuptools\command\install.py", line 76, i
n run
    self.do_egg_install()
  File "C:\Python27\lib\site-packages\setuptools\command\install.py", line 96, i
n do_egg_install
    self.run_command('bdist_egg')
  File "C:\Python27\lib\distutils\cmd.py", line 326, in run_command
    self.distribution.run_command(command)
  File "C:\Python27\lib\distutils\dist.py", line 971, in run_command
    cmd_obj.ensure_finalized()
  File "C:\Python27\lib\distutils\cmd.py", line 109, in ensure_finalized
    self.finalize_options()
  File "C:\Python27\lib\site-packages\setuptools\command\bdist_egg.py", line 94,
 in finalize_options
    ei_cmd = self.ei_cmd = self.get_finalized_command("egg_info")
  File "C:\Python27\lib\distutils\cmd.py", line 312, in get_finalized_command
    cmd_obj.ensure_finalized()
  File "C:\Python27\lib\distutils\cmd.py", line 109, in ensure_finalized
    self.finalize_options()
  File "C:\Python27\lib\site-packages\setuptools\command\egg_info.py", line 85,
in finalize_options
    self.vtags = self.tags()
  File "C:\Python27\lib\site-packages\setuptools\command\egg_info.py", line 185,
 in tags
    ):  version += '-r%s' % self.get_svn_revision()
  File "C:\Python27\lib\site-packages\setuptools\command\egg_info.py", line 233,
 in get_svn_revision
    dirurl = data[0][3]
IndexError: list index out of range

Have you found a Trac ticket regarding this?

comment:3 Changed 5 years ago by Ryan J Ollos

Description: modified (diff)

comment:4 Changed 5 years ago by anonymous

Resolution: invalid
Status: newclosed

Seems like this is not TracJSGantt. Or at least not only TracJSGantt. If you find that I'm making a common mistake, please reopen.

comment:5 Changed 5 years ago by Benjamin Lau

In case anyone else runs across this since this was the first hit I found for this error... I think I found the cause of this problem. It's due to the fact that Subversion 1.7 has changed their working copy metadata format. Because of this setuptools existing get_svn_revision method no longer works. It needs to be modded to support this. You can read more about this here on the Trac ticket system.

comment:6 in reply to:  5 Changed 5 years ago by anonymous

Replying to netjunki:

In case anyone else runs across this since this was the first hit I found for this error... I think I found the cause of this problem. It's due to the fact that Subversion 1.7 has changed their working copy metadata format. Because of this setuptools existing get_svn_revision method no longer works. It needs to be modded to support this. You can read more about this here on the Trac ticket system.

Thanks @netjunki. I had to revert to older versions of bitten to work around this so I will give upgrading a shot and report back what I find.

comment:7 Changed 5 years ago by Ryan J Ollos

Same issue in #9565. Thanks for the info netjunki!

comment:8 Changed 4 years ago by Ryan J Ollos

Keywords: setuptools svn-1.7 added

This issue is seen again in #10778.

comment:9 Changed 3 years ago by Ryan J Ollos

Resolution: invalidcantfix

comment:10 Changed 2 years ago by anonymous

I'm seeing the same problem when attempting installation with 'sudo easy_install -Z -U http://trac-hacks.org/svn/xmlrpcplugin/trunk' (following http://trac-hacks.org/wiki/XmlRpcPlugin on a Trac 1.0.1-4 from Bitnami). This is currently blocking any possible use of Trac.

comment:11 Changed 2 years ago by Ryan J Ollos

Your problem is with Setuptools, not Trac. See comment:4:ticket:10778 for solutions. Please ask on the trac:MailingList if you have additional questions.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Chris Nelson.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.