Modify

Opened 5 years ago

Closed 5 years ago

#9876 closed defect (duplicate)

AttributeError: 'Ticket' object has no attribute '_get_db_for_write'

Reported by: babu@… Owned by: Daniel Atallah
Priority: highest Component: PendingTicketPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /ticket/812, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'2172f1a91080ac5b655ef0a1',
 'action': u'leave',
 'cnum': u'5',
 'comment': u'',
 'field_cc': u'',
 'field_description': u'3. Team 3 ( Saji)\r\n \r\n    Server            IP  \r\n    a. IE-6        192.168.0.65\r\n    b. IE-7        192.168.0.66\r\n    c. IE-8        192.168.0.67\r\n    Users: user1 -5\r\n    Password : rain\r\n\r\nI have tried to connect the virtual machines with the above details and it not working. \r\n\r\nIs virtual machines have installed Microsoft office to open docx? \r\n\r\n\r\n',
 'field_keywords': u'',
 'field_milestone': u'Applications',
 'field_priority': u'major',
 'field_reporter': u'babu@rainconcert.in',
 'field_summary': u'Virtual machine are not working',
 'field_type': u'defect',
 'id': u'812',
 'replyto': u'',
 'submit': u'Submit changes',
 'ts': u'2012-02-21 05:55:42.477387+00:00'}

User agent: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0

System Information

Trac 0.12
Genshi 0.6
mod_python 3.2.8
pysqlite 2.5.5
Python 2.4.3 (#1, Sep 3 2009, 15:37:12)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
setuptools 0.6c11
SQLite 3.3.6
Subversion 1.4.2 (r22196)
jQuery 1.4.2

Enabled Plugins

BlackMagicTicketTweaks 0.12r1
RemovePendingStatusPlugin 0.0.4
TracAccountManager 0.2.1dev-r7737
TracPermRedirect 2.0

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.12-py2.4.egg/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.12-py2.4.egg/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.12-py2.4.egg/trac/ticket/web_ui.py", line 169, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.12-py2.4.egg/trac/ticket/web_ui.py", line 538, in _process_ticket_request
    self._do_save(req, ticket, action)
  File "/usr/lib/python2.4/site-packages/Trac-0.12-py2.4.egg/trac/ticket/web_ui.py", line 1233, in _do_save
    cnum=internal_cnum):
  File "/usr/lib/python2.4/site-packages/Trac-0.12-py2.4.egg/trac/ticket/model.py", line 353, in save_changes
    listener.ticket_changed(self, comment, author, old_values)
  File "build/bdist.linux-i686/egg/removepending/remove_pending.py", line 30, in ticket_changed
AttributeError: 'Ticket' object has no attribute '_get_db_for_write'

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Ryan J Ollos

Component: SELECT A HACKPendingTicketPlugin
Owner: changed from anonymous to Daniel Atallah

comment:2 Changed 5 years ago by Ryan J Ollos

Duplicate of #7808.

comment:3 Changed 5 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Daniel Atallah.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.