Modify

Opened 5 years ago

Closed 22 months ago

#10708 closed defect (fixed)

DistributionNotFound: Python>=2.4

Reported by: anonymous Owned by: Mark Ryan
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description (last modified by Ryan J Ollos)

Hi,

i cannot run the TracChildTickets 2.5.2 plugin. In the Trac logs i can see:

Skipping "Tracchildtickets 2.5.2": ("DistributionNotFound: Python>=2.4" not found)

what could this be?

Attachments (0)

Change History (8)

comment:1 in reply to:  description Changed 5 years ago by anonymous

Replying to anonymous:

i am using Trac 0.12.4, Python 2.5.4 and build the plugin from the 0.12 branch (Tracchildtickets-2.5.2-py2.5)

comment:2 Changed 5 years ago by Mark Ryan

Status: newassigned

Hi

What version of setuptools do you have installed?

Take a look at #7017 and #9589.

Regards Mark

comment:3 Changed 5 years ago by Ryan J Ollos

Putting an install_requires for Python causes problems, as noted in other tickets. Just delete the line from setup.py and it should install fine.

comment:4 Changed 4 years ago by Ryan J Ollos

Description: modified (diff)

comment:5 Changed 4 years ago by anonymous

Installed c:\python25\lib\site-packages\tracchildtickets-2.5.2-py2.5.egg
Processing dependencies for tracchildtickets==2.5.2
Searching for Python>=2.4
Reading http://pypi.python.org/simple/Python/
Reading http://www.python.org
Reading http://www.python.org/2.3
Reading http://www.python.org/2.4
Reading http://www.python.org/2.4.1
Reading http://www.python.org/2.5
Reading http://www.python.org/download/
Best match: Python 3.3.3
Downloading http://www.python.org/ftp/python/3.3.3/Python-3.3.3.tgz
Processing Python-3.3.3.tgz
Last edited 4 years ago by Ryan J Ollos (previous) (diff)

comment:6 Changed 4 years ago by anonymous

Best match is not Python 3.3, but Python 2.5

comment:7 Changed 4 years ago by Ryan J Ollos

That demonstrates the problem with including Python as a dependency in install_requires. Would you really want the installation of a plugin to result in the download and installation of Python?

A different approach is to check whether the Python interpreter that you are executing from meets a requirement, and if not then issue an error. [13472] is an example of that approach.

comment:8 Changed 22 months ago by Ryan J Ollos

Resolution: fixed
Status: assignedclosed

In 15066:

2.5.4dev: Revise installation requirements

Enforce Trac >= 1.0. Genshi and Python version is enforced
by Trac.

Fixes #10708, #11208. Refs #12364.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Mark Ryan.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.