Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12436 closed defect (duplicate)

Commit Changelog Reference # anywhere in string

Reported by: anonymous Owned by: Richard Liao
Priority: normal Component: TracTicketChangelogPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Is there a way to get this plugin to function with the #ticketNum located anywhere in the string. Right now it only works at the beginning of the string. My log pattern in my ini file is:

log_pattern = \s*#%s[:\s]+.*

I would like to be able to say:

"The changes in this commit pertain to ticket #40"

rather than be restricted to:

"#40 relates to this commit"

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

#11821 proposes to use trac:wiki:CommitTicketUpdater#Usage syntax to extract tokens such as Refs #1 anywhere in the string. So closing as a duplicate of #11821.

For now, you could try replacing re.match with re.search. You might get too many false positives though. That's one reason why I think it would be better to use the syntax of CommitTicketUpdater.

comment:2 Changed 7 years ago by Ryan J Ollos

See also #7884.

comment:3 Changed 7 years ago by anonymous

Is the syntax of CommitTicketUpdater functional, or are you still developing it? If it is functional, why does the log_pattern exist in the configuration file. If this is not functional, you should have mentioned that.

comment:4 Changed 7 years ago by Ryan J Ollos

The features described in #11821, including utilization of CommitTicketUpdater syntax, have not yet been implemented.

comment:5 Changed 7 years ago by anonymous

Thank you, any timetable for their release?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Richard Liao.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.