Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12618 closed defect (duplicate)

InvalidQuery: Ungültiges Attribut 'http'

Reported by: Ryan J Ollos Owned by: Steffen Hoffmann
Priority: normal Component: TagsPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

We should trap and log InvalidQuery errors.

2015-12-21 05:25:45,192 Trac[formatter] ERROR: Macro ListTagged(http:/api.weheartit.com/Samira31?page=3&before=1358541378000255356) failed:
Traceback (most recent call last):
  File "build/bdist.linux-i686/egg/trac/wiki/formatter.py", line 789, in _macro_formatter
    return macro.ensure_inline(macro.process(args))
  File "build/bdist.linux-i686/egg/trac/wiki/formatter.py", line 358, in process
    text = self.processor(text)
  File "build/bdist.linux-i686/egg/trac/wiki/formatter.py", line 342, in _macro_processor
    text, self.args)
  File "build/bdist.linux-i686/egg/tractags/macros.py", line 261, in expand_macro
    results = sorted(query_result, key=lambda r: \
  File "build/bdist.linux-i686/egg/tractags/api.py", line 436, in query
    if query(tags, context=resource):
  File "build/bdist.linux-i686/egg/tractags/query.py", line 269, in __call__    return self.match(self, terms, context)
  File "build/bdist.linux-i686/egg/tractags/query.py", line 293, in match
    return _match(node)
  File "build/bdist.linux-i686/egg/tractags/query.py", line 279, in _match    return _match(node.left) and _match(node.right)
  File "build/bdist.linux-i686/egg/tractags/query.py", line 288, in _match
    )(node.left.value, node.right, context)  File "build/bdist.linux-i686/egg/tractags/query.py", line 427, in _invalid_handler
    raise InvalidQuery(_("Invalid attribute '%s'") % name)
InvalidQuery: Ungültiges Attribut 'http'

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #12542.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.