Modify

Opened 5 years ago

Closed 4 years ago

#12619 closed defect (duplicate)

Exclude from backlink when text is included in WikiMacros like TicketQuery

Reported by: kyb.stefan@… Owned by:
Priority: normal Component: BackLinksMacro
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

If a "TicketQuery" includes the same text as a wiki-page is named the wiki-page is added mistakenly as backlink

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Ryan J Ollos

#5903 and #10818 closed as duplicates.

Issue reproduced by inserting the following into a page: [[TicketQuery(keywords=TracAdmin)]], and viewing backlinks on the TracAdmin page.

I think we need to impose the constraint that only TracLinks be considered as valid referring pages. That gives us the possibility of using Trac's wiki parser. However, we should also look closely at the approach taken by AutoWikifyPlugin.

I've also closed #8797 as a duplicate since using Trac's wiki parser should allow us to support WikiCreole as well.

comment:2 Changed 5 years ago by Ryan J Ollos

I'm not sure when I'll have time to work on this one. PatchWelcome, though.

comment:3 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #13077.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.